uva 725Division



 

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0through 9 once each, such that the first number divided by the second is equal to an integer N, where$2
\le N \le 79$. That is,


abcde / fghij = N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer  N . An input of zero is to terminate the program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:


xxxxx / xxxxx = N

xxxxx / xxxxx = N

.

.


In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions forN.". Separate the output for two different values of N by a blank line.

Sample Input 

61
62
0

Sample Output 

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62

根据 除数暴力,第一次写的很乱,看了别人的题解感觉很简洁。

#include <iostream>
#include<cstdio>
#include<cstring>

using namespace std;
int a[10];
int judge(int x)
{
    int y;
    while(x)
    {
        y=x%10;
        x=x/10;
        a[y]++;
    }
    return 0;
}

int main()
{
    int n,m;
    int num=0;
    while(scanf("%d",&n)!=EOF && n)
    {
        if(num) printf("\n");
        num++;
        m=0;
        int flag=0;
        for(int i=0;i<10;i++)
            for(int j=0;j<10;j++)
                if(i!=j)
                   for(int k=0;k<10;k++)
                   if(i!=k && j!=k)
                     for(int x=0;x<10;x++)
                        if(i!=x && j!=x && k!=x)
                          for(int y=0;y<10;y++)
                             if(i!=y && j!=y && k!=y && x!=y)
                             {
                                 int cnt=0;
                                 memset(a,0,sizeof(a));
                                 a[i]=1;
                                 a[j]=1;
                                 a[k]=1;
                                 a[x]=1;
                                 a[y]=1;
                                 m=y+x*10+k*100+j*1000+i*10000;
                                 int s=m*n;
                                 judge(s);
                                 for(int i=0;i<10;i++)
                                    if(a[i]==1)
                                    cnt++;
                                 if(cnt==10)
                                 {
                                     flag=1;
                                     printf("%05d / %05d = %d\n",s,m,n);
                                 }
                             }
        if(!flag) printf("There are no solutions for %d.\n",n);
    }

    return 0;
}

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int a[10];
int judge(int x,int y)
{
    if(y>98765) return 0;
    memset(a,0,sizeof(a));
    if(x<10000) a[0]=1;
    while(x)
    {
        a[x%10]++;
        x=x/10;
    }
    while(y)
    {
        a[y%10]++;
        y=y/10;
    }
    int cnt=0;
    for(int i=0;i<10;i++)
        if(a[i]==1)
        cnt++;
    if(cnt == 10) return 1;
    else return 0;
}
int main()
{
    int n;
    int num=0;
    while(scanf("%d",&n)!=EOF && n)
    {
        if(num) printf("\n");
        num++;
        int flag=0;

        for(int i=1234;i<=98765;i++)
        {
            if(judge(i,i*n))
            {
                flag=1;
                printf("%05d / %05d = %d\n",i*n,i,n);
            }
        }
        if(!flag) printf("There are no solutions for %d.\n",n);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值