UVA 10391 Compound Words



You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn


题意:找出由两个单词构成的单词

想了半天都没想到,看了题解才发现原来这么合情理,智商碾压了

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <map>
using namespace std;
const int MAX = 120000+5;

map<string, int> Map;
char str[MAX][100];

int main()
{
    int n = 0;
    Map.clear();
    while(~scanf("%s", str[n]) && strcmp(str[n], "END"))
    {
        Map[str[n]] = 1;
        n++;
    }
    for(int i=0;i<n;i++)
    {
        int len = strlen(str[i]);
        for(int j = 0;j<len;j++)
        {
            char temp1[100];
            char temp2[100];
            memset(temp1,'\0',sizeof(temp1));  //注意初始化,不初始化WA
            memset(temp2,'\0',sizeof(temp2));
            strncpy(temp1,str[i],j);
            strncpy(temp2,str[i]+j,len-j);
            if(Map[temp1] && Map[temp2])
            {
                printf("%s\n",str[i]);
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值