POJ 1270Following Orders(拓扑+DFS)

6 篇文章 0 订阅
3 篇文章 0 订阅

Following Orders
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4348 Accepted: 1751

Description

Order is an important concept in mathematics and in computer science. For example, Zorn's Lemma states: ``a partially ordered set in which every chain has an upper bound contains a maximal element.'' Order is also important in reasoning about the fix-point semantics of programs.  


This problem involves neither Zorn's Lemma nor fix-point semantics, but does involve order.  
Given a list of variable constraints of the form x < y, you are to write a program that prints all orderings of the variables that are consistent with the constraints.  


For example, given the constraints x < y and x < z there are two orderings of the variables x, y, and z that are consistent with these constraints: x y z and x z y.  

Input

The input consists of a sequence of constraint specifications. A specification consists of two lines: a list of variables on one line followed by a list of contraints on the next line. A constraint is given by a pair of variables, where x y indicates that x < y.  


All variables are single character, lower-case letters. There will be at least two variables, and no more than 20 variables in a specification. There will be at least one constraint, and no more than 50 constraints in a specification. There will be at least one, and no more than 300 orderings consistent with the contraints in a specification.  


Input is terminated by end-of-file.  

Output

For each constraint specification, all orderings consistent with the constraints should be printed. Orderings are printed in lexicographical (alphabetical) order, one per line.  


Output for different constraint specifications is separated by a blank line.  

Sample Input

a b f g
a b b f
v w x y z
v y x v z v w v

Sample Output

abfg
abgf
agbf
gabf

wxzvy
wzxvy
xwzvy
xzwvy
zwxvy
zxwvy
题意: 第一行输入若干字母,第二行输入字母间的关系,输入所有可能的拓扑排序
思路:mark[]记录哪些字母存在,然后g[][]记录是否存在关系,in[]存每一个点的入度,然后搜索就可以了
     从in[]为0的点开始,然后将其与之相连的即g[i][] == 1的入度都减一,进入下一个点的搜索,回溯是要恢复现场把原来     入度减一的点在恢复++状态,同时i的入度变成0
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string.h>
#include <algorithm>
using namespace std;
int in[30];
int g[30][30],vis[30],mark[30];
int n,temp[30];
void dfs(int x, int cnt)
{
    if(cnt == n )
    {
        for(int i = 0; i < n; i++)
            printf("%c", temp[i] + 'a');
        printf("\n");
        return;
    }
    for(int i = 0; i < 26; i++)
    {
        if(mark[i] == 1 && in[i] == 0 && vis[i] == 0)
        {
            vis[i] = 1;
            temp[cnt] = i;
            in[i] = -1;

            for(int j = 0; j < 26; j++)
            {
                if(g[i][j] == 1 && in[j] > 0)
                {
                    in[j] --;
                }
            }
            dfs(i,cnt + 1);
            vis[i] = 0;
            for(int j = 0; j < 26; j++)
            {
                if(g[i][j] == 1)
                in[j] ++;
            }
            in[i] = 0;
        }
    }
}
int main()
{
    char s[500];
    int num = 0;
    while(gets(s))
    {
        n = 0;
        memset(in,0,sizeof(in));
        memset(g,0,sizeof(g));
        memset(vis,0,sizeof(vis));
        memset(mark,0,sizeof(mark));
        int len = strlen(s);
        for(int i = 0; i < len; i++)
        {
            if(s[i] != ' ')
            {
                mark[s[i] - 'a'] = 1;
                n++;
            }
        }
        gets(s);
        len = strlen(s);
        for(int i = 0; i < len; i += 4)
        {
            in[s[i + 2] - 'a'] ++;
            g[s[i] - 'a'][s[i + 2] - 'a'] = 1;
        }
        if(num != 0)
            printf("\n");
        num ++;
        dfs(0,0);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 1321 排兵布阵题可以使用 DFS 算法求解。 题目要求在一个 n x n 的棋盘上,放置 k 个棋子,其中每行、每列都最多只能有一个棋子。我们可以使用 DFS 枚举每个棋子的位置,对于每个棋子,尝试将其放置在每一行中未被占用的位置上,直到放置了 k 个棋子。在 DFS 的过程中,需要记录每行和每列是否已经有棋子,以便在尝试放置下一个棋子时进行判断。 以下是基本的 DFS 模板代码: ```python def dfs(row, cnt): global ans if cnt == k: ans += 1 return for i in range(row, n): for j in range(n): if row_used[i] or col_used[j] or board[i][j] == '.': continue row_used[i] = col_used[j] = True dfs(i + 1, cnt + 1) row_used[i] = col_used[j] = False n, k = map(int, input().split()) board = [input() for _ in range(n)] row_used = [False] * n col_used = [False] * n ans = 0 dfs(0, 0) print(ans) ``` 其中,row 代表当前尝试放置棋子的行数,cnt 代表已经放置的棋子数量。row_used 和 col_used 分别表示每行和每列是否已经有棋子,board 则表示棋盘的状态。在尝试放置棋子时,需要排除掉无法放置的位置,即已经有棋子的行和列,以及棋盘上标记为 '.' 的位置。当放置了 k 个棋子时,即可计数一次方案数。注意,在回溯时需要将之前标记为已使用的行和列重新标记为未使用。 需要注意的是,在 Python 中,递归深度的默认限制为 1000,可能无法通过本题。可以通过以下代码来解除限制: ```python import sys sys.setrecursionlimit(100000) ``` 完整代码如下:

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值