UVA101The Blocks Problem(小模拟+STL)

B - The Blocks Problem
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Download as PDF
Background
Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands.
The Problem
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0i<n1 as shown in the diagram below:

\begin{figure}
\centering
\setlength{\unitlength}{0.0125in} %
\begin{picture}
(2...
...raisebox{0pt}[0pt][0pt]{$\bullet
\bullet \bullet$ }}}
\end{picture}
\end{figure}

Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:
move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.
move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.
pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.
pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.
quit
terminates manipulations in the block world.
Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.
The Input
The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.
The Output
The output should consist of the final state of the blocks world. Each original block position numbered i ( 0i<n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don’t put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).
Sample Input
10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit
Sample Output
0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

Miguel Revilla
2000-04-06

犹豫脑袋不清醒debug了好久
死循环(超时)的原因是
搬砖是搬到pos[b]上 而不是b上。。

ps:对于那种debug了很久的题。。不管是啥我都想放上来(微笑.jpg
昨晚上打了cf 虽然很弱鸡 打酱油
但是我发现
没有想象中辣么阔怕
以前不想打cf一是太晚了
二大概和我不想打定级赛心情是一样的= =
但还是要面对定出一个青铜五的事实啊= =
希望以后头脑清醒点。。。(我好菜啊.jpg

//  Created by ZYD in 2015.
//  Copyright (c) 2015 ZYD. All rights reserved.
//

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <climits>
#include <string>
#include <sstream>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define Size 100000
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array) memset(array,0,sizeof(array))
typedef pair<int,int> P;

queue<int> xque[1005],dque;
int n;
int a,b;
vector<int>sta[30];
int pos[30];
void move(int x){
    int y=pos[x];
    int i;
    for(i=0;i<sta[y].size();i++){
        if(sta[y][i]==x) break;
    }
    for(int j=i+1;j<sta[y].size();j++){
        int p=sta[y][j];
        sta[p].push_back(p);
        pos[p]=p;
    }
    int j=sta[y].size()-1;
    while(sta[y][j]!=x&& j>=0){
        sta[y].pop_back();
        j--;
    }
    // sta[y].pop_back();
//  cout<<y<<' '<<sta[y].size()<<endl;
}
void pile(int a,int b){
    int x=pos[a],y=pos[b];
    //cout<<x<<a<<endl;
    // cout<<y<<b<<endl;
    int i;
    for(i=0;i<sta[x].size();i++)
        if(sta[x][i]==a) break;
    for(int j=i;j<sta[x].size();j++){
        int p=sta[x][j];
        sta[y].push_back(p);
        pos[p]=y;
    }
//  cout<<a<<' '<<x<<endl;
    int j=sta[x].size()-1;
    // for(int i=0;i<=j;i++) 
        // cout<<sta[x][i]<<' '; cout<<endl;
    while(sta[x][j]!=a&& j>=0){
        sta[x].pop_back();
        j--;
    }
    sta[x].pop_back();
}
int main()
{
    freopen("in.txt","r",stdin);
    scanf("%d\n",&n);
    for(int i=0;i<n;i++) {sta[i].push_back(i);pos[i]=i;}
    char s1[10],s2[10];
    while(~scanf("%s %d %s %d\n",s1,&a,s2,&b)){
        if(s1[0]=='q'){
            break;
        }
        //cout<<a<<' '<<b<<":"<<endl;
        //cout<<pos[a]<<' '<<pos[b]<<endl;
        if(a==b||pos[a]==pos[b]) continue;
        if(s1[0]=='m'&& s2[1]=='n'){
            move(a);move(b);
            sta[pos[a]].pop_back();
            sta[pos[b]].push_back(a);
            pos[a]=pos[b];
        }
        if(s1[0]=='m'&& s2[1]=='v'){
            move(a);
            sta[pos[a]].pop_back();
            sta[pos[b]].push_back(a);
            pos[a]=pos[b];
        }
        if(s1[0]=='p'&& s2[1]=='n'){
            move(b);
            pile(a,b);
        }
        if(s1[0]=='p'&& s2[1]=='v'){
            pile(a,b);
        }
    //  cout<<sta[1].size()<<endl;
    //  cout<<"a:"<<a<<' '<<sta[a].size()<<endl;
    //  cout<<"b:"<<b<<' '<<sta[b].size()<<endl;
    } 
    for(int i=0;i<n;i++){
        cout<<i<<":";//cout<<sta[i].size()<<"***"<<endl;
         for(int j=0;j<sta[i].size();j++)
             cout<<' '<<sta[i][j];
        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值