HDU 5806 NanoApe Loves Sequence Ⅱ


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.


Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤109


Output
For each test case, print a line with one integer, denoting the answer.


Sample Input
1
7 4 2
4 2 7 7 6 5 1


Sample Output

18

就是相当于找到合适的队列(符合要求的)以后,然后不管其他的,大的就去替代大的,小的就去替代小的,逐个替代,只要满足的第k大的数字比m不小就可以

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<time.h>
using namespace std;
#define ll long long
const int N=200005;
int t,n,m,k,l,r,a[N],tmp;
ll ans;
//移动是相对于tmp来说的
void left(){
    if (a[l++]>=m)
        tmp--;
}
void right(){
    if (a[++r]>=m)
        tmp++;
}
int main()
{
    int i;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for (i=1;i<=n;i++)
            scanf("%d",&a[i]);
        l=1;
        r=0;
        ans=0;
        tmp=0;
        for (i=1;i<=n-k+1;i++)
            {
                while (tmp<k&&r<n)
                    right();
                if (tmp>=k)
                    ans+=n-r+1;
                    //printf("n-r:%d ans:%d\n",n-r,ans);
                left();
            }
            printf("%lld\n",ans);
    }
    return 0;
}

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
#define ll long long
const int N=100010;
int main()
{
    int n,m,i,k,t;
    scanf("%d",&t);
    while (t--)
    {
        ll ans=0ll;
        scanf("%d%d%d",&n,&m,&k);
        queue<int> Q;
        for (i=0;i<n;i++)
        {
            int x;
            scanf("%d",&x);
            if (x>=m)
                Q.push(i);  //重点是这里
            if (Q.size()<k)
                continue;
            while (Q.size()>k)
                Q.pop();
            ans+=Q.front()+1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值