HDU - 5806 NanoApe Loves Sequence Ⅱ(尺取)

NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination! 

In math class, NanoApe picked up sequences once again. He wrote down a sequence with nn numbers and a number mm on the paper. 

Now he wants to know the number of continous subsequences of the sequence in such a manner that the kk-th largest number in the subsequence is no less than mm. 

Note : The length of the subsequence must be no less than kk.

 

Input

The first line of the input contains an integer TT, denoting the number of test cases. 

In each test case, the first line of the input contains three integers n,m,kn,m,k. 

The second line of the input contains nn integers A1,A2,...,AnA1,A2,...,An, denoting the elements of the sequence. 

1≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤1091≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤109

 

Output

For each test case, print a line with one integer, denoting the answer.

 

Sample Input

1
7 4 2
4 2 7 7 6 5 1

Sample Output

18

 

题目大意:一个长度为n的序列,求出所有符合条件的连续的子序列的个数(子序列的第K大的数不小于m)

解题思路:可以使用尺取法来做,从左往右遍历,用一个变量t来记录不小于m的个数,当t>=k时,此时符合条件的来序列为n-j+1,这是因为当后面还有数比m大时,显然第k大的数一定不小于m,当后面所有的数有比m小的时,依然有第k大的数不小于m ,所以从当前一次往后取数形成的子序列都符合条件。

注意:输入数据过大,使用cin会超时,使用scanf

AC代码;

#include<iostream>
using namespace std;
const int maxn=2e5+10;
int main()
{
	int num[maxn];
	int t,m,n,k;
	cin>>t;
	while(t--)
	{
		cin>>n>>m>>k;
		long long ans=0;
		int i=0,j=0,t=0;
		for(i=0;i<n;i++)
			scanf("%d",&num[i]);
		for(i=0;i<n;i++)
		{
			while(j<n&&t<k)
			{
				if(num[j]>=m)
					t++;
				j++;
			}
			if(t>=k)
				ans+=n-j+1;
			if(num[i]>=m)
				t--;
		}
		cout<<ans<<endl;
	}
	return 0; 
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值