HDU 5305 Friends(2015 Multi-University Training Contest 2)

116 篇文章 0 订阅
21 篇文章 0 订阅

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1946    Accepted Submission(s): 975


Problem Description
There are  n  people and  m  pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these  n  people wants to have the same number of online and offline friends (i.e. If one person has  x  onine friends, he or she must have  x  offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer  T (T=100) , indicating the number of testcases. 

For each testcase, the first line contains two integers  n (1n8)  and  m (0mn(n1)2) , indicating the number of people and the number of pairs of friends, respectively. Each of the next  m  lines contains two numbers  x  and  y , which mean  x  and  y  are friends. It is guaranteed that  xy  and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
  
  
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
  
  
0 2
 

Author
XJZX
 

Source

题目大意:

有 n个人,m对朋友关系,朋友之间可以选择成为 在线朋友 或者 离线朋友,每个人都想有相同数目的 在线朋友 和 离线朋友。(比如一个人有 x 个在线朋友,那么他必须有 x 个离线朋友)但是不同的人 x 可以不同。求有多少种方案可以满足他们的要求。

样例解释

2 两个测试用例
3 3 三个人,三对朋友关系
1 2 1 2 是朋友,他们可以选择成为离线或者在线朋友
2 3 2 3 是朋友,他们可以选择成为离线或者在线朋友
3 1 3 4 是朋友,他们可以选择成为离线或者在线朋友
4 4 同理
1 2
2 3
3 4
4 1

解题思路

此处输入图片的描述

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxm=100;
int x[maxm];
int y[maxm];
int n,m;
int ans;
int vis1[maxm];
int vis2[maxm];
int sum[maxm];
void dfs(int pos)
{
    if(pos==m+1)
    {
        int ok=1;
        for(int i=1; i<=n; i++)
        {
            if(vis1[i]!=vis2[i])
            {
                ok=0;
                break;
            }
        }
        if(ok)
        {
            ans++;
            return;
        }
    }
    if(vis1[x[pos]]<(sum[x[pos]]>>1)&&vis1[y[pos]]<(sum[y[pos]]>>1))
    {
        vis1[x[pos]]++;
        vis1[y[pos]]++;
        dfs(pos+1);
        vis1[x[pos]]--;
        vis1[y[pos]]--;
    }
    if(vis2[x[pos]]<(sum[x[pos]]>>1)&&vis2[y[pos]]<(sum[y[pos]]>>1))
    {
        vis2[x[pos]]++;
        vis2[y[pos]]++;
        dfs(pos+1);
        vis2[x[pos]]--;
        vis2[y[pos]]--;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(sum,0,sizeof(sum));
        memset(vis1,0,sizeof(vis1));
        memset(vis2,0,sizeof(vis2));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            sum[x[i]]++;
            sum[y[i]]++;
        }
        int ok=1;
        for(int i=1; i<=n; i++)
        {
            if(sum[i]%2)
            {
                ok=0;
                printf("0\n");
                break;
            }
        }
        if(ok)
        {
            ans=0;
            dfs(1);
            printf("%d\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值