hihocoder1094 Lost in the City

描述

Little Hi gets lost in the city. He does not know where he is. He does not know which direction is north.

Fortunately, Little Hi has a map of the city. The map can be considered as a grid of N*M blocks. Each block is numbered by a pair of integers. The block at the north-west corner is (1, 1) and the one at the south-east corner is (N, M). Each block is represented by a character, describing the construction on that block: ‘.’ for empty area, ‘P’ for parks, ‘H’ for houses, ‘S’ for streets, ‘M’ for malls, ‘G’ for government buildings, ‘T’ for trees and etc.

Given the blocks of 33 area that surrounding Little Hi(Little Hi is at the middle block of the 33 area), please find out the position of him. Note that Little Hi is disoriented, the upper side of the surrounding area may be actually north side, south side, east side or west side.

输入

Line 1: two integers, N and M(3 <= N, M <= 200).
Line 2~N+1: each line contains M characters, describing the city’s map. The characters can only be ‘A’-‘Z’ or ‘.’.
Line N+2~N+4: each line 3 characters, describing the area surrounding Little Hi.

输出

Line 1~K: each line contains 2 integers X and Y, indicating that block (X, Y) may be Little Hi’s position. If there are multiple possible blocks, output them from north to south, west to east.
(可能有多种结果,安装北到南,西到东的顺序输出)
样例输入

    8 8
    ...HSH..
    ...HSM..
    ...HST..
    ...HSPP.
    PPGHSPPT
    PPSSSSSS
    ..MMSHHH
    ..MMSH..
    SSS
    SHG
    SH.

样例输出

    5 4

思路:
先找到有Hi的地方(不计算矩阵的最外圈),然后拿数据给出的Hi的3*3地图的进行四种方向的变换再和每一个用Hi地方进行对比

AC代码

#include<cstdio>
#include<iostream>
using namespace std;

int main()
{
    //freopen("in.txt", "r", stdin);
    int n,m;
    while(cin >> n >> m){
        //cin >> n >> m;
        char a[n][m];
        char h[3][3];
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin >> a[i][j];
        
        for(int i=0; i<3; i++)
            for(int j=0; j<3; j++)
                cin >> h[i][j];
        //int flag=0;
        for (int i = 1; i < n-1; i++)
        {
            for (int j = 1; j < m-1; j++)
                if(a[i][j] == h[1][1])     //找到有H的地方,然后比较周围事物
                {
                    int down = (a[i-1][j-1]==h[2][2] && a[i-1][j]==h[2][1] && a[i-1][j+1]==h[2][0] && a[i][j-1]==h[1][2] && a[i][j+1]==h[1][0]
                        && a[i+1][j-1]==h[0][2] && a[i+1][j]==h[0][1] && a[i+1][j+1]==h[0][0]);
                    int up = (a[i-1][j-1]==h[0][0] && a[i-1][j]==h[0][1] && a[i-1][j+1]==h[0][2] && a[i][j-1]==h[1][0] && a[i][j+1]==h[1][2]
                        && a[i+1][j-1]==h[2][0] && a[i+1][j]==h[2][1] && a[i+1][j+1]==h[2][2]);
                    int left = (a[i-1][j-1]==h[2][0] && a[i-1][j]==h[1][0] && a[i-1][j+1]==h[0][0] && a[i][j-1]==h[2][1] && a[i][j+1]==h[0][1]
                        && a[i+1][j-1]==h[2][2] && a[i+1][j]==h[1][2] && a[i+1][j+1]==h[0][2]);
                    int right = (a[i-1][j-1]==h[0][2] && a[i-1][j]==h[1][2] && a[i-1][j+1]==h[2][2] && a[i][j-1]==h[0][1] && a[i][j+1]==h[2][1]
                        && a[i+1][j-1]==h[0][0] && a[i+1][j]==h[1][0] && a[i+1][j+1]==h[2][0]);
                    if(down || up || left || right){
                            //flag = 1;
                            cout << i+1 << " " << j+1 << endl;
                            //break;
                        }
                }
            //if(flag) break;
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值