hihoCoder #1135 : Magic Box

描述

The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some balls into the box one by one. The balls are in three colors: red®, yellow(Y) and blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find what is the maximum number of balls in the box ever.

For example, let’s assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.

输入

Line 1: x y z

Line 2: the sequence consisting of only three characters ‘R’, ‘Y’ and ‘B’.

For 30% data, the length of the sequence is no more than 200.

For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.

输出

The maximum number of balls in the box ever.

提示

Another Sample

Sample InputSample Output
0 0 0
RBYRRBY
4

样例输入

    1 2 3
    RRYBRBRYBRY

样例输出

    7

先解释一下这个题的意思:

给出了放球的序列,又给出了x、y、z的值,从第一个球开始往box里面放球,假设|Cr-Cy|、 |Cy-Cb|、 |Cb-Cr|从小到大排序为b[0]、b[1]、b[2],而x、y、z从小到大排序为a[0]、a[1]、a[2]如果满足a[0] == b[0] && a[1]==b[1] && a[2]==b[2],那么此时的球就会消失。
我们要输出的内容就是在球消失之前盒子中能放的最多的球,那么是不是第一次消失前盒子中能放的最多的球的数量呢?显然不是,因为第一次消失之前有5个球,消失归0后可能第二次消失需要9个球,所以需要把每个球的全部遍历。

AC代码:

#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

int main()
{
    int a[3];
    string seq;
    cin >> a[0] >> a[1] >> a[2] >> seq;
    sort(a, a+3);
    int cr=0,cy=0,cb=0, maxx=0;
    for(int i=0; i<seq.size(); i++){
        if(seq[i] == 'R')   cr++;
        else if(seq[i] == 'Y')  cy++;
        else    cb++;

        maxx = maxx>(cr+cy+cb)?maxx:(cr+cy+cb);   //当前存在的最多的球,不可以用i,因为i是遍历过的球,而球是会归0的
        int b[] = {abs(cr-cy), abs(cy-cb), abs(cb-cr)};
        sort(b, b+3);

        if(a[0] == b[0] && a[1]==b[1] && a[2]==b[2]){     //消失一次后,球归0
            cr = 0;
            cy = 0;
            cb = 0;
        }
    }
    cout << maxx;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值