UVA - 10110 Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off?
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output " yes" if the light is on otherwise " no" , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

题意:
给出N,可以知道其因子数目,如果数目为奇数就可以打开,yes
如果数目为偶数就不可以打开,no
多写几个数,可以知道,可以开方的数其因子为奇数;
不可以开方的数其因子为偶数,题意也就转化为判断该数是否可以开方;



 
#include<stdio.h>
#include<math.h>
#include<iostream>
#include<string.h>

using namespace std;

int main(){
	long long int n;
	while(scanf("%lld",&n))
	{
		if(n == 0)
			break;
		long long int m;
		m = (int)sqrt(n);
		if(n == m*m)
			cout << "yes"<<endl;
		else 
			cout << "no"<<endl;

		
	
	}

	return 0;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值