HDU 5038

Grade

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 456    Accepted Submission(s): 248


Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output
For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input
  
  
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
 

Sample Output
  
  
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000



题意:

用给出的公式求出每个蘑菇的grade,求出现次数最多的grade。

如果有多个grade出现的次数一样多,且还有其他的grade,则把这些出现次数最多的grade按升序输出;

否则,输出“Bad Mushroom”。 


#include <cstdio>
#include <cstring>

const int N = 10004;
int cnt[N];

int main() {
    int T, n, w, cas = 0;
    scanf("%d",&T);
    while(T--) {
        scanf("%d", &n);
        int S= 0; //有几个不同的s
        int Max_cnt = 0; //出现次数最多的数出现的次数
        int Max = 0, Min = 10005; //s的最大最小值
        memset(cnt, 0, sizeof(cnt));
        for(int i = 0; i < n; i++) {
            scanf("%d",&w);
            int s = 10000 - (100 - w) * (100 - w);
            if(s > Max) Max = s;
            if(s < Min) Min = s;
            if(!cnt[s]) S++;
            cnt[s]++;
            if(cnt[s] > Max_cnt) Max_cnt = cnt[s];
        }
        printf("Case #%d:\n", ++cas);
        if(Max_cnt * S == n && S > 1)
            printf("Bad Mushroom\n");
        else {
            int p = 0;
            for(int i = Min; i <= Max; i++) {
                if(cnt[i] == Max_cnt) {
                    if(p) printf(" ");
                    printf("%d", i);
                    p = 1;
                }
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值