UVA - 729 The Hamming Distance Pro

  The Hamming Distance Problem 

The Hamming distance between two strings of bits (binary integers) is the number of corresponding bit positions that differ. This can be found by using XOR on corresponding bits or equivalently, by adding corresponding bits (base 2) without a carry. For example, in the two bit strings that follow:

                               A      0 1 0 0 1 0 1 0 0 0
                               B      1 1 0 1 0 1 0 1 0 0
                            A XOR B = 1 0 0 1 1 1 1 1 0 0

The Hamming distance (H) between these 10-bit strings is 6, the number of 1's in the XOR string.

Input 

Input consists of several datasets. The first line of the input contains the number of datasets, and it's followed by a blank line. Each dataset contains  N , the length of the bit strings and  H , the Hamming distance, on the same line. There is a blank line between test cases.

Output 

For each dataset print a list of all possible bit strings of length  N  that are Hamming distance  H  from the bit string containing all 0's (origin). That is, all bit strings of length  N  with exactly  H 1 's printed in ascending lexicographical order.


The number of such bit strings is equal to the combinatorial symbol C(N,H). This is the number of possible combinations of N-H zeros and H ones. It is equal to 

\begin{displaymath}{N!} \over {(N-H)! H!}\end{displaymath}

This number can be very large. The program should work for $1 \le H \le N\le 16$.

Print a blank line between datasets.

Sample Input 

1

4 2

Sample Output 

0011
0101
0110
1001
1010
1100
 
题意:
给出一个N的长度,以及h 个 1,剩余的 N - h 个 0;
要求出他们的全排列; 依旧用next_permutation(a,a+N) (应用在实数类型)
 
#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAX 1000

int main () {
	int N, n, m;
	int  a[MAX];
    //string a;
	cin >> N;
	while (N--) {
		cin >> n >> m;
		for (int i = 0; i < n - m; i++)
			a[i] = 0;
		for (int i = n- m; i < n; i++)
			a[i] = 1;
		for (int i = 0; i < n; i++)
			cout << a[i];
		cout <<endl;
		while (next_permutation(a,a+n)) {
			for (int i = 0; i < n; i++)
			cout << a[i];
		cout <<endl;
		}
		if (N)
		cout << endl;
		
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值