UVA - 639 Don't Get Rooked

  Don't Get Rooked 

In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4$\times$4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legalprovided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them.


The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration.

Input 

The input file contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer  n  that is the size of the board; n  will be at most 4. The next  n  lines each describe one row of the board, with a `  . ' indicating an open space and an uppercase `  X ' indicating a wall. There are no spaces in the input file.

Output 

For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.

Sample Input 

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output 

5
1
5
2
4



#include <iostream>
#include <cstdio>
#include <cstring>
#define N 10
using namespace std;
int n;
char a[N][N];
int vis[N][N]; // -1 已经放完 0表示墙 1表示可以放入

int fun(int r, int c) {
   // for (int i = 0; i <= r; i++){ 
   for (int i = r; i >= 0; i--) {  // 依次往前推,因此倒着过来
		if (vis[i][c] < 0) return 0;
		else if (vis[i][c] == 0)
			break;
	}

    //for (int i = 0; i <= c; i++) {
	for (int i = c; i >= 0; i--) {
	if (vis[r][i] < 0) return 0;
		else if (vis[r][i] == 0) break; 
	}
	return 1;
}

int dfs(int i,int j) {
	int kase = 0,max = 0;
	while (i < n) {
		if (vis[i][j] && fun (i,j))	 {
			vis[i][j] = -1;
			kase = dfs(i,j) + 1;
			if (kase > max)
				max = kase;
			vis[i][j] = 1;
		}

		if (j >= n-1) {
			i++;
			j = 0;
		}
		else {
			j++;	
		}
	}

	return max;
}

int main () {
	while (scanf("%d",&n) != EOF) {
		if (n == 0) break;
		for (int i = 0; i < n; i++) {
			scanf("%s",a[i]);
			for (int j = 0; j < n; j++) {
				if (a[i][j] == '.')
					vis[i][j] = 1;
				else
					vis[i][j] = 0;
			}
		}
		int k = dfs(0,0);
		printf("%d\n",k);	
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值