poj1226--Substrings

Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2

/

# include<stdio.h>

# include<string.h>

int main()

{

       int i,j,k,n,t,len,flag,minlen;

       char str[110][110],a[110],b[110],c[110];

       scanf("%d",&t);

       while(t--)

       {

              scanf("%d",&n);

              minlen=220;

              flag=0;

              for(i=0;i<n;i++)     //因为公共子串的长度不会长于最短的那个字符串,所以用minlen记录n个字符串的最短长度,并把那个最短的字符串存在c中

              {

                     scanf("%s",str[i]);

                     len=strlen(str[i]);

                     if(minlen>len)

                     {

                            minlen=len;

                            strcpy(c,str[i]);

                     }

              }

              for(i=minlen;i>0;i--)//i为子串的长度

              {

                     for(j=0;j<=minlen-i;j++)//当子串的长度为i时,存在minlen-i种可能的字串。例如ABCD,当子串长度为4时,子串只有一种,即ABCD;当子串的长度为3时,有ABC,BCD两种;当子串长度为2时,有AB,BC,CD三种子串

                     {

                            strncpy(a,&c[j],i);//strncpy(*str1,*str2,n)就是从str2中copy i个字符赋给str1;

                            a[i]='\0';

                            strcpy(b,a);

                            b[i]='\0';

                            strrev(b);

                            for(k=0;k<n;k++)

                            {

                                   if(strstr(str[k],a)==NULL&&strstr(str[k],b)==NULL)//strstr(s1,s2)如果s1,是s2的子串,返回s1第一次出现的地址,否则返回NULL;

                                          break;

                            }

                            if(k==n)

                            {

                                   flag=i;

                                   break;

                            }

                     }

                     if(flag)

                            break;

              }

              printf("%d\n",flag);

       }

       return 0;

}

 

 

Language:
Substrings
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 7402Accepted: 2475

Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值