UVA - 188 Perfect Hash

 Perfect Hash 

Perfect Software, Inc. has obtained a government contract to examine text flowing through a high-speed network for the occurrence of certain words. Your boss, Wally Perfect, has designed a parallel processing system which checks each word against a group of small perfect hash tables.

A perfect hash function maps its input directly to a fully occupied table. Your job is to construct the perfect hash functions from the lists of words in each table. The hash function is of the form tex2html_wrap_inline63 , where C is a positive integer you are to discover, w is an integer representation of an input word, and n is the length of the table. C must be as small as possible. Note that tex2html_wrap_inline73 is the floor function and that tex2html_wrap_inline75 for some real number R is the largest integer that is tex2html_wrap_inline79 .

Here are Wally's notes on the subject:

Let tex2html_wrap_inline81 consist of positive integers tex2html_wrap_inline83 . The problem is to find the smallest positive integer C such that

tex2html_wrap_inline87 for all tex2html_wrap_inline89 .

C must be a multiple of at least one element of W.

If some

tex2html_wrap_inline95 for all tex2html_wrap_inline97 ,

then the next largest C that could resolve the conflict is at least

displaymath61

Since all such conflicts must be resolved, it is advantageous to choose the largest candidate from among the conflicts as the next C to test.

You are to convert each word to a number by processing each letter from left to right. Consider `a' to be 1, `b' to be 2, tex2html_wrap_inline103 , `z' to be 26. Use 5 bits for each letter (shift left by 5 or multiply by 32). Thus `a' = 1, `bz' = tex2html_wrap_inline105 .

Input

Input to your program will be a series of word lists, one per line, terminated by the end-of-file. Each line consists of between two and thirteen words of at most five lower case letters each, separated from each other by at least one blank. There will always be at least one one-letter word.

For each list, you are to print the input line. On the next line, print the C for the hash function determined by the list. Print a blank line after each C.

C will always fit in a 32-bit integer.

Sample input

this is a test of some words to try out
a bee see dee
the of and to a in that is i it with for as

Sample output

this is a test of some words to try out
17247663

a bee see dee
4427

the of and to a in that is i it with for as
667241
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int c,k;
int x[15];
int f(){
	int i,j;
	for(i=0;i<k;i++)
		for(j=i+1;j<k;j++)
			if((c/x[i]%k)==(c/x[j]%k)){
				c=min((c/x[i]+1)*x[i],(c/x[j]+1)*x[j]);
				f();
				return 0;
			}
}
int main()
{
	int i,j,a,b;
	char s[200];
	while(gets(s)!=NULL){
		memset(x,0,sizeof(x));
		a=strlen(s);
		for(i=0,k=0;i<a;i++){
			if(s[i]==' '){
				k++;
				while(s[i+1]==' ')
					i++;
			}
			else 
				x[k]=x[k]*32+s[i]-'a'+1;
		}
		k++;
		sort(x,x+k);
		c=x[0];
		f();
		printf("%s\n%d\n\n",s,c);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值