【POJ 2505】A multiplication game(博弈)

题意描述:Stan和Ollie玩游戏,两人轮流,首先Stan开始把1乘以一个2到9之间的整数,接着Ollie再将前一个数乘以一个2到9之间的整数。最先使这个数不小于n的人获胜。

解题思路:与其说是博弈,不如说是找到了规律,S胜:2-9(0+2)——9;O胜:10-18 (9+1)——9*2;S胜:19-162 (2*9+1)——9*2*9;O胜:163-324 (9*2*9+1)——9*2*9*2;S胜:324-2916 (9*2*9*2+1)——9*2*9*2*9。

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

AC代码 

#include<stdio.h>
#include<string.h>
int main()
{
	int a[25],n,i;
	while(~scanf("%d",&n))
	{
		int ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			ans=ans^a[i];
		}
		if(ans==0)
			printf("No\n");
		else
			printf("Yes\n");
	}
	return 0;
}

努力努力再努力

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值