题目
BaoBao has just found a positive integer sequence a_1, a_2, \dots, a_na1,a2,…,an of length nn from his left pocket and another positive integer bb from his right pocket. As number 7 is BaoBao's favorite number, he considers a positive integer xx lucky if xx is divisible by 7. He now wants to select an integer a_kak from the sequence such that (a_k+b)(ak+b) is lucky. Please tell him if it is possible.
Input
There are multiple test cases. The first line of the input is an integer TT (about 100), indicating the number of test cases. For each test case:
The first line contains two integers nn and bb (1 \le n, b \le 1001≤n,b≤100), indicating the length of the sequence and the positive integer in BaoBao's right pocket.
The second line contains nn positive integers a_1, a_2, \dots, a_na1,a2,…,an (1 \le a_i \le 1001≤ai≤100), indicating the sequence.
Output
For each test case output one line. If there exists an integer a_kak such that a_k \in \{a_1, a_2, \dots, a_n\}ak∈{a1,a2,…,an} and (a_k + b)(ak+b) is lucky, output "Yes" (without quotes), otherwise output "No" (without quotes).
Sample Input
4 3 7 4 5 6 3 7 4 7 6 5 2 2 5 2 5 2 4 26 100 1 2 4Sample Output
No Yes Yes YesHint
For the first sample test case, as 4 + 7 = 11, 5 + 7 = 12 and 6 + 7 = 13 are all not divisible by 7, the answer is "No".
For the second sample test case, BaoBao can select a 7 from the sequence to get 7 + 7 = 14. As 14 is divisible by 7, the answer is "Yes".
For the third sample test case, BaoBao can select a 5 from the sequence to get 5 + 2 = 7. As 7 is divisible by 7, the answer is "Yes".
For the fourth sample test case, BaoBao can select a 100 from the sequence to get 100 + 26 = 126. As 126 is divisible by 7, the answer is "Yes".
AC代码👑
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
int t,n,m,a;
cin>>t;
while(t--)
{
cin>>n>>m;
int f=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&a);
if((a+m)%7==0)
{
f=1;
}
}
if(f==1)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}