Doing Homework again HDU 1789 (贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 93 Accepted Submission(s): 81
 
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score. 
 
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 
Output
For each test case, you should output the smallest total reduced score, one line per test case.
 
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
 
Sample Output
0
3
5
 
Author
lcy
 

题意:

有n门课,每一门课有一个限定的时间和超过时间后罚的分数,然后假定每一天只能完成一门课,问如何安排时间去完成这些课,使得罚分最少并输出。


为了让最后的结果最小,首先要把socre从大到小排序。然后每当考虑一门课,扫描期限内的天数(注意要从最后的期限往前枚举,给其它课尽可能的留下余地),如果能完成,就将该天标记,否则计入总罚分,以此类推。

#include <iostream>
#include <cmath>
#include <string>
#include <algorithm>
#include <string.h>
using namespace std;
struct Node {
    int deadline;
    int reduce;
}node[1005];
int visited[1005];
int main() {
    int t;
    int n;
    cin >> t;
    while (t--) {
        int ans = 0;
        memset(node, 0, sizeof(node));
        memset(visited, 0, sizeof(visited));
        cin >> n;
        for (int i = 0; i < n; ++i) {
            cin >> node[i].deadline;
        }
        for (int i = 0; i < n; ++i) {
            cin >> node[i].reduce;
        }
        
        sort(node, node + n, [](const Node& n1,const Node& n2){return n1.reduce > n2.reduce || (n1.reduce == n2.reduce && n1.deadline < n2.deadline);});
        
        for (int i = 0; i < n; ++i) {
            int j = node[i].deadline;
            for (; j >= 1; --j) {
                if (!visited[j]) {
                    visited[j] = 1;
                    break;
                }
            }
            if (j == 0)
                ans += node[i].reduce;
        }
        cout << ans << endl;
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值