POJ2376 Cleaning Shifts (贪心)

Cleaning Shifts

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 3
Problem Description
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
 

Input
* Line 1: Two space-separated integers: N and T 
 * Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
 

Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
 

Sample Input
  
  
3 10 1 7 3 6 6 10
 

Sample Output
  
  
2
 
这是一个区间完全覆盖的贪心,按照左端点递增排序,然后取下一个线段原则是左端点要与上一个线段相连接,然后尽可能取右端点大的线段。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <set>
#include <queue>
using namespace std;
const int INF = 0x3fffffff;
int n, t;
struct Node {
    int left, right;
}node[30000];
bool cmp(const Node& n1, const Node& n2) {
    return n1.left < n2.left || (n1.left == n2.left && n1.right > n2.right);
}
int main() {
        //freopen("in.txt", "r", stdin);
    while (cin >> n >> t) {
        for (int i = 0; i < n; ++i) {
            cin >> node[i].left >> node[i].right;
            if (node[i].left > node[i].right) {
                swap(node[i].left, node[i].right);
            }
        }
        sort(node, node + n, cmp);
        
        int ans = 0;
        int begin = 1, end = 0;
        int i = 0;
        while (begin <= t) {
            for (; i < n && node[i].left <= begin; ++i) {
                if (node[i].right > end) {
                    end = node[i].right;
                }
            }
            if (end >= begin) {
                begin = end + 1;
                ans++;
            } else
                break;
        }
        if (begin <= t)
            ans = -1;
        cout << ans << endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值