poj 2395 Out of Hay (最小生成树)

Problem K

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.
 

Input
* Line 1: Two space-separated integers, N and M. <br> <br>* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
 

Output
* Line 1: A single integer that is the length of the longest road required to be traversed.
 

Sample Input
  
  
3 3 1 2 23 2 3 1000 1 3 43
 

Sample Output
  
  
43
 

题目大意:1号农场的草被牛吃完了,Bessie必须从其他农场运草回来,总共有N个农场,Bessie要

去其他所有的农场运草回来,他想要使总路程最短并且路线能连接所有的农场。必须要考虑到路上

带的水袋大小。因为水袋大小和路线中距离最长的两个农场之间的路有关,现在Bessie想要求出满

足要求的路线中两个农场之间最长的路距离是多少。

思路:求最小生成树中边最大的。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <cmath>
#include <vector>
#include <queue>
#include <utility>
using namespace std;
const int INF = 0x3fffffff;
struct Node {
    int u, v, w;
}node[10005];
int fa[2005];
int n, m;
int find(int x) {
    if (fa[x] == x)
        return x;
    fa[x] = find(fa[x]);
    return fa[x];
}
void merge(int x, int y) {
    int fx = find(x);
    int fy = find(y);
    if (fx != fy) {
        fa[fy] = fx;
    }
}
bool cmp(const Node& n1, const Node& n2) {
    return n1.w < n2.w;
}
int main() {
        //freopen("in.txt", "r", stdin);
    cin >> n >> m;
    for (int i = 1; i <= n; ++i) {
        fa[i] = i;
    }
    
    for (int i = 0; i < m; ++i) {
        cin >> node[i].u >> node[i].v >> node[i].w;
    }
    sort(node, node + m, cmp);
    
    int num = 0;
    int ans = -1;
    for (int i = 1; i < n; ++i) {
        for ( ; num < m; ++num) {
            int fu = find(node[num].u);
            int fv = find(node[num].v);
            if (fu != fv) {
                ans = max(ans, node[num].w);
                merge(fv, fu);
                break;
            }
        }
    }
    cout << ans << endl;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值