【最小生成树专题】POJ 2395 Out of Hay (瓶颈生成树)

http://bailian.openjudge.cn/practice/2395/

POJ 2395:Out of Hay

描述

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

输入

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

输出

* Line 1: A single integer that is the length of the longest road required to be traversed.

样例输入

3 3
1 2 23
2 3 1000
1 3 43

样例输出

43

提示

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

来源

USACO 2005 March Silver

思路

最大长度最小问题<===>求最小生成树的最大边问题(最小瓶颈生成树)

题目大意:1号农场的草被牛吃完了,Bessie必须从其他农场运草回来,总共有N个农场,Bessie要去其他所有的农场运草回来,他想要使总路程最短并且路线能连接所有的农场。必须要考虑到路上带的水袋大小。因为水袋大小和路线中距离最长的两个农场之间的路有关,现在Bessie想要求出满足要求的路线中两个农场之间最长的路距离是多少。

思路:满足要求的路线其实就是最小生成树,路线中两个农场之间最长的路距离就是最小生成树上最长的边

这样用Kruskal求最小生成树的时候,用Max求出最小生成树上最长的边。

AC Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;
const int nmax=2010;
const int mmax=1e4+10;
int n,m;//点数、边数 
int maxval;//生成树的最大边 
struct Edge{
	int u,v;
	ll val;
}edge[mmax]; 
bool cmp(Edge a,Edge b){
	return a.val<b.val;//按照边权从小到大排序,求最小生成树 
}
int father[nmax]; 
int findFather(int u){
	if(u==father[u]) return u;
	else{
		int f=findFather(father[u]);
		father[u]=f;
		return f;
	}
}
void init(int n){
	for(int i=1;i<=n;i++){
		father[i]=i;
	}
}

void Kruskal1(){//求出最小生成树中的最大边
	init(n);
	ll ans=0;
	ll cnt=0; 
	for(int i=0;i<m;i++){//边编号:0~m-1 
		int fu=findFather(edge[i].u);
		int fv=findFather(edge[i].v);
		if(fu!=fv){
			father[fu]=fv;
			//printf("%lld %lld\n",ans,edge[i].val);
			ans+=edge[i].val;
			cnt++;
			//printf("%lld\n",ans);
			if(maxval<edge[i].val){//贪心找最大边 
				maxval=edge[i].val;
			} 
			if(cnt==n-1)
				break;
		}
	}
	if(cnt==n-1)
		printf("%lld\n",maxval);
	else
		return ;
}



int main(int argc, char** argv) {
	while(scanf("%d %d",&n,&m)!=EOF){
		memset(father,0,sizeof(father));
		for(int i=0;i<m;i++){
			scanf("%d %d %lld",&edge[i].u,&edge[i].v,&edge[i].val);
		}
		sort(edge,edge+m,cmp);
		maxval=-0x3f3f3f3f;
	    Kruskal1();//求出最小生成树的最大边
		
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值