POJ 2407-Relatives (欧拉函数)

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 4
Problem Description
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz. 
 

Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case. 
 

Output
For each test case there should be single line of output answering the question posed above.
 

Sample Input
  
  
7 12 0
 

Sample Output
  
  
6 4
 
求小于等于n且与n互质的数
定理:
设A, B, C是跟m, n, mn互质的数的集,据中国 剩余定理,A*B和C可建立一一对应的关系。因此φ(n)的值使用 算术基本定理便知,
 
 
例如
 
与欧拉定理、 费马小定理的关系
对任何两个互质的正整数a, m(m>=2)有
即欧拉定理
当m是质数p时,此式则为:
即费马小定理。
代码按照定理来写的(不能用线性筛因为复杂度1e9

#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stdio.h>
#include <stack>
using namespace std;
int eular(int num) {
    int ans = 1;
    for (int i = 2;  i * i <= num; ++i) {
        if (num % i == 0) {
            num /= i;
            ans *= i - 1;
            while (num % i == 0) {
                num /= i;
                ans *= i;
            }
        }
    }
    if (num > 1)
        ans *= (num - 1);
    return ans;
}
int main() {
        //freopen("1.txt", "r", stdin);
    int n;
    while (cin >> n && n) {
        cout << eular(n) << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值