hdu 2586 How far away ? (LCA 离线tarjan)

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18126    Accepted Submission(s): 7037


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source

复习一下图论的知识。。
关于LCA的离线算法可以看一下这个。。。 http://www.cnblogs.com/JVxie/p/4854719.html。 写的挺好的(我懒得写
看了好多的博客。。的模板都不是很喜欢其风格。。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <utility>
#include <vector>
using namespace std;
const int maxn = 80305;
int fa[maxn], dist[maxn], visited[maxn];
int head[maxn];
//树的边集
struct Node {
    int u, v, w, next;
}node[maxn];
int num;

struct Edge {
    int u, v, lca;
};
//查找的点与点的集合
vector<Edge> edges;

int find(int x) {
    if (x == fa[x])
        return x;
    return fa[x] = find(fa[x]);
}

void dfs(int u) {
    fa[u] = u;
    visited[u] = 1;
    for (int i = 0; i < edges.size(); ++i) {
        //边中的某点与当前访问的点有关,且另一个点已经被访问过了
        if (edges[i].u == u && visited[edges[i].v]) {
            //找当前的公共祖先
            edges[i].lca = find(edges[i].v);
        } else if (edges[i].v == u && visited[edges[i].u]) {
            edges[i].lca = find(edges[i].u);
        }
    }
    
    for (int i = head[u]; i != -1; i = node[i].next) {
        int v = node[i].v;
        int w = node[i].w;
        if (!visited[v]) {
            dist[v] = dist[u] + w;
            dfs(v);
            //回溯时标记父节点,才能在当前dfs中找到公共祖先
            fa[v] = u;
        }
    }
}
void init() {
    num = 0;
    memset(head, -1, sizeof(head));
    memset(dist, 0, sizeof(dist));
    edges.clear();
    memset(visited, 0, sizeof(visited));
}
void add(int u, int v, int w) {
    node[num] = {u, v, w, head[u]};
    head[u] = num++;
    node[num] = {v, u, w, head[v]};
    head[v] = num++;
}

int main() {
        //freopen("in.txt", "r", stdin);
    ios::sync_with_stdio(false);
    std::cin.tie(0);
    //给vector提前扩大空间,减少开销
    edges.reserve(250);
    int t;
    cin >> t;
    while (t--) {
        init();
        int n, m;
        cin >> n >> m;
        for (int i = 1; i < n; ++i) {
            int u, v, w;
            cin >> u >> v >> w;
            add(u, v, w);
        }
        
        for (int i = 0; i < m; ++i) {
            int u, v;
            cin >> u >> v;
            edges.push_back({u, v, 0});
        }
        
        dfs(1);
        
        for (int i = 0; i < m; ++i) {
            cout << dist[edges[i].u] + dist[edges[i].v] - 2 * dist[edges[i].lca] << endl;
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值