USACO SECTION 1.2 Palindromic Squares

Palindromic Squares
Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696
/*
ID: conicoc1
LANG: C
TASK: palsquare
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int i;

void Hex(int Number,int B,char *PalNumber)  //将10进制转化成B进制 
{
	i=0;
	if(Number<B)
	{
		if(Number>=10)
			PalNumber[i]=Number+'A'-10;
		else
			PalNumber[i]=Number+'0';
	}
	else
	{
		Hex(Number/B,B,PalNumber);
		if(Number%B>=10)
			PalNumber[i]=Number%B+'A'-10;
		else
			PalNumber[i]=Number%B+'0';
	}
	PalNumber[++i]='\0';
}

int PalJudge(char *PalNumber)  //判断是否是回文
{
	int i,j;
	for(i=0;PalNumber[i]!='\0';i++);
	j=i-1;
	i=0;
	do{
		if(PalNumber[i]!=PalNumber[j])
			return 0;
		j--;
		i++;
	}while(i<=j);
	
	return 1;
}
 
int main()
{
	FILE *fin,*fout,*ftxt;
	fin=fopen("palsquare.in","r");
	fout=fopen("palsquare.out","w");
	
	char OriginNumber[20];
	char PalNumber[20];
	
	int B;
	fscanf(fin,"%d",&B);
	
	int i;
	for(i=1;i<=300;i++)
	{
		Hex(i*i,B,PalNumber);
		if(PalJudge(PalNumber))
		{
			Hex(i,B,OriginNumber);
			fprintf(fout,"%s %s\n",OriginNumber,PalNumber);
		}
	}
	
	return 0;
}


在保存转换保存字符数组的时候纠结了一会儿,用循环是逆序保存,所以最后用了递归

一开始下标定义成static int型,发现当第二次引用函数时,i没有从头地址开始,纠结了一会儿,改用全局变量。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值