USACO SECTION 1.2 Dual Palindromes

Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28
/*
ID: conicoc1
LANG: C
TASK: dualpal
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int i;

void Hex(int Number,int B,char *PalNumber)  //将10进制转化成B进制 (B<=10)
{
	i=0;
	if(Number<B)
	{
		PalNumber[i]=Number+'0';
	}
	else
	{
		Hex(Number/B,B,PalNumber);
		PalNumber[i]=Number%B+'0';
	}
	PalNumber[++i]='\0';
}

int PalJudge(char *PalNumber)  //判断是否是回文
{
	int i,j;
	for(i=0;PalNumber[i]!='\0';i++);
	j=i-1;
	i=0;
	do{
		if(PalNumber[i]!=PalNumber[j])
			return 0;
		j--;
		i++;
	}while(i<=j);
	
	return 1;
}


int main()
{
	FILE *fin,*fout,*ftxt;
	fin=fopen("dualpal.in","r");
	fout=fopen("dualpal.out","w");
	
	int N,S;
	
	fscanf(fin,"%d %d",&N,&S);
	int Count=0;    //计数器 当大于等于N时结束循环
	int DualPal; //计数器 当大于等于2时 打印
	
	int x,y;
	char PalNumber[20];
	
	for(x=S+1;Count<N;x++)   //对于每个数字x
	{
		for(DualPal=0,y=10;y>=2;y--)  //对该数的每个进制进行判断 
		{
			Hex(x,y,PalNumber);
			if(PalJudge(PalNumber))
			{	
				printf("%s\n",PalNumber);
				DualPal++;
			}
			if(DualPal>=2)
			{
				fprintf(fout,"%d\n",x);
				Count++;
				break;
			}
		}
	}
	 
	return 0;
	
}


和上一题几乎一样。。。

return 0; 忘了

判断回文的if语句后面多加了分号。。

小细节的编码错误太多。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值