zoj3129----------------Japan 逆序对~~

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input starts with T - the number of test cases. Each test case starts with three numbers - N, M, K. Each of the next K lines contains two numbers - the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:

Test case [case number]: [number of crossings]

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
 
 
先对左元素按升序排序,相等的再按有元素升序排
 
最后求右边元素序列的逆序对即可,
 
注意,结果用long long存,否则WA
 
 
代码:
 
#include <iostream>
#include <climits>
#include <algorithm>
using namespace std;


typedef struct Road 
{
	int n;
	int m;	
}NM;

int cmp(Road a,Road b)
{
	if(a.n!=b.n)
		return a.n<b.n;
	else
		return a.m<b.m;		
}

long long merge(long long A[],int p,int q,int r)
{
	int n1=q-p+1;
	int n2=r-q;
	long long count=0;
	long long *L=new long long[n1+2];
	long long *R=new long long[n2+2];
	for(int i=1;i<=n1;i++)
		L[i]=A[p+i-1];	
	for(int i=1;i<=n2;i++)
		R[i]=A[q+i];
	L[n1+1]=INT_MAX;
	R[n2+1]=INT_MAX;
	int i,j; 
	i=1;
	j=1;
	for(int k=p;k<=r;k++)
	{
		if(L[i]<=R[j])
		{
			count=count+j-1;
			A[k]=L[i];
			i++;	
		}
		else
		{
			A[k]=R[j];
			j++;	
		}	
	}
	delete[]L;
	delete[]R;
	return count;
}


long long merge_sort(long long A[],int p,int r)
{
	long long count=0;
	if(p<r)
	{
		int q=(p+r)/2;
		count=count+merge_sort(A,p,q);	
		count=count+merge_sort(A,q+1,r);
		count=count+merge(A,p,q,r);
	}
	return count;
}

int main()
{
	int T;
	cin>>T;
	for(int j=1;j<=T;j++)
	{
		int N,M,K;
		cin>>N>>M>>K;
		Road NM[K];
		for(int i=0;i<K;i++)
			cin>>NM[i].n>>NM[i].m;
		sort(NM,NM+K,cmp);
		long long A[K+1];
		for(int i=1;i<=K;i++)
			A[i]=NM[i-1].m;
		long long count;
		count=merge_sort(A,1,K);
		cout<<"Test case "<<j<<": "<<count<<endl;	
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值