集训笔记---二分法(POJ NO.2456 Aggressive cows)

8 篇文章 0 订阅

Aggressive cows

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20095 Accepted: 9513

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

还是说,需要寻找到一个X让这个X去满足条件C,即 所有牛的牛舍所在的位置能满足,任意两头牛之间的距离可以大于X,那么使用二分法去枚举这样一个距离,然后用条件函数C来判断这样的一个X循环往复,最终找到一个最小的X

#include<cstdio>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int MAX_N = 100010;
int n, m;
int a[MAX_N];
bool C(int x);
int main(void)
{
    int i;
    scanf("%d %d", &n, &m);
    for(i = 0; i < n; i++)
    {
        scanf("%d", &a[i]);
    }
    sort(a, a+n);//对牛舍进行排序 
    int lb = 0;
    int ub = INF;
    //初始化二分搜索的初始条件 
    while(ub - lb > 1)
    {
        int mid = (ub + lb) / 2;
        if(C(mid))//枚举出一个mid判断其可行性 
        {
            lb = mid;
        }
        else
        {
            ub = mid;
        }
    }
    printf("%d\n", lb);
    return 0;
}
bool C(int x)
{
    int last = 0;
    for(int i = 1; i < m; i++)//每头牛都进行遍历,确保任意两头牛都满足题意 
    {
        int crt = last + 1;//先让一头牛位置固定,然后判断后面的一头牛的位置 
        while((crt < n) && (a[crt] - a[last] < x))
        {
            crt++;
        }
        if(crt == n)//如果内层循环终止的原因是crt == n,那么就说明穷尽所有牛舍都不能找到解 
        {
            return false;
        }
        last = crt;//更新位置信息 
    }
    return true;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值