集训笔记---队列应用(HDUOJ NO.1509 Windows Message Queue )结构体充当队列元素

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9041    Accepted Submission(s): 3746


 

Problem Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

 

 

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

 

 

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

 

 

Sample Input

 

GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET

 

 

Sample Output

 

EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!

STL里面的优先队列默认对象是int,并且使用vector存储数据,当需要使用结构体构建队列元素的时候,我们就要重载C++里面的operator<操作符,重载使用的是bool friend operator < (edge a, edge b)这个友函数,具体操作请看注释

AC代码

#include<cstdlib>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct edge
{
    int pr;//存储优先级 
    int num;//存储指令输入的顺序 
    int digit;
    char name[500];
    bool friend operator < (edge a, edge b)//返回true时b优先级高于a 
    {
        if(a.pr == b.pr) 
        {
            return a.num > b.num;//优先级相等时使用FIFO判断哪一条指令先出去 
        }
        return a.pr > b.pr;//优先级数字越大代表的优先级反而小 
    }
};
int main(void)
{
    priority_queue<edge> que;
    char s[10];
    int k = 1;
    while(scanf("%s", s) != EOF)
    {
        if(strcmp(s, "GET") == 0)
        {
            if(que.empty())
            {
                printf("EMPTY QUEUE!\n");
            }
            else
            {
                printf("%s %d\n", que.top().name, que.top().digit);
                que.pop();
            }
        }
        if(strcmp(s, "PUT") == 0)
        {
            edge t;
            scanf("%s %d %d", t.name, &t.digit, &t.pr);
            t.num = k;
            que.push(t);
            k++;
        }
    }
    return 0;

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值