1089. Insert or Merge (25)
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:10 3 1 2 8 7 5 9 4 6 0 1 2 3 7 8 5 9 4 6 0Sample Output 1:
Insertion Sort 1 2 3 5 7 8 9 4 6 0Sample Input 2:
10 3 1 2 8 7 5 9 4 0 6 1 3 2 8 5 7 4 9 0 6Sample Output 2:
Merge Sort 1 2 3 8 4 5 7 9 0 6
写到这又得面壁去了,基本的插入的排序调了半天
代码:
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
bool perInsertSort(vector<int> &src,vector<int> &dest,int start)
{
int pos = start;
int poit = src[start];
for(int j= start -1;j>=0;--j){//找出插入位置
if(src[j] > poit) {
pos = j;
}else{
break;
}
}
for(int j=start -1;j>=pos;--j){
src[j+1]=src[j];
}
src[pos]=poit;
if(src==dest) return true;
return false;
}
/*
void mergeSort(vector<int> &src,vector<int> &dest,int start,int end,bool &isFind,bool &stop)
{//使用递归的归并排序
if(stop) return;
if(end - start ==1 ) return;
int middle = (end+start)/2;
mergeSort(src,dest,start,middle,isFind,stop);
mergeSort(src,dest,middle,end,isFind,stop);
inplace_merge(src.begin()+start,src.begin()+middle,src.begin()+end);
if(isFind){
stop = true;
}
if(src == dest){
isFind = true;
}
}
*/
void mergeSort(vector<int> &src,int step)
{
int len = src.size();
if(step >= len) return ;//子区间的长度已经大于src的长度
int i = 0;
while(i<len){
vector<int>::iterator iter = src.begin();
int start = i;
int middle = i+step;
int end = middle+step;
middle =(middle >= len ? len:middle);
end = (end >= len ? len:end);
inplace_merge(iter+start,iter+middle,iter+end);
i=end;
}
}
void print(const vector<int> &src)
{
bool first = true;
for(int i=0;i<src.size();++i){
if(first){
cout<<src[i];
first = false;
}else{
cout<<" "<<src[i];
}
}
}
int main()
{
int n;
cin>>n;
int x;
vector<int> src,dest;
int repeat = n;
while(repeat --){
cin>>x;
src.push_back(x);
}
repeat = n;
while(repeat --){
cin>>x;
dest.push_back(x);
}
vector<int> temp(src.begin(),src.end());
bool isInsertSort=false;
for(int i= 1;i<src.size();++i){
isInsertSort = perInsertSort(src,dest,i);
if(isInsertSort){
cout<<"Insertion Sort"<<endl;
if(i+1 <= src.size()){
perInsertSort(src,dest,i+1);
print(src);
cout<<endl;
break;
}
}
}
if(!isInsertSort){
int step = 1;
while(step < temp.size()){
if(temp==dest){
cout<<"Merge Sort"<<endl;
mergeSort(temp,step);
print(temp);
cout<<endl;
break;
}
mergeSort(temp,step);
step *= 2;
}
}
return 0;
}