1058. A+B in Hogwarts (20)

题目链接:http://www.patest.cn/contests/pat-a-practise/1058

题目:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

分析:

数制转换
17个银西可等于一个加隆,而29个科纳等于一个西可

AC代码:

#include<stdio.h>
using namespace std;
struct Number{
 int high;
 int mid;
 int low;
};
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 Number num1, num2,num_sum;
 scanf("%d.%d.%d", &num1.high, &num1.mid, &num1.low);
 scanf("%d.%d.%d", &num2.high, &num2.mid, &num2.low);
 num_sum.low = num1.low + num2.low;
 num_sum.mid = num1.mid + num2.mid;
 num_sum.high = num1.high + num2.high;
 num_sum.mid += num_sum.low / 29;
 num_sum.high += num_sum.mid / 17;
 num_sum.mid = num_sum.mid % 17;
 num_sum.low = num_sum.low % 29;
 printf("%d.%d.%d\n", num_sum.high, num_sum.mid, num_sum.low);
 return 0;
}


截图:


——Apie陈小旭

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值