nyoj 题目 BUYING FEED 贪心算法

BUYING FEED

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution.
 Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     
0   1   2  3   4   5
    
---------------------------------
         
1       1   1                Available pounds of feed
         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
1
2 5 3                 
3 1 2
4 1 2
1 1 1
样例输出
7
来源
第三届河南省程序设计大赛
上传者
ACM_赵铭浩
大意:

一个人去接一些店接k磅饲料,这些饲料店刚好位于一条直线,同x轴一样,每个店只能出售Fi磅,单价Ci,他拉一磅饲料,走一个单位长度就要多付1美分,给出终点坐标E,求他拉k磅饲料到E点时最少花销。

思路:

将每家店到E点的距离算出来,与单价相加,作为新的单价,这样就在不用考虑运费的问题了。然后按新单价排序,贪心算法先取单价低的。

#include<stdio.h>
#include<stdlib.h>
struct data
{
	int x;
	int f;
	int c;
	int m;
}s[100];
int cmp(const void*a,const void*b)
{
	return (*(data*)a).m>(*(data*)b).m?1:-1;
}
int main()
{
	int num,k,e,n;
	scanf("%d",&num);
	while(num--)
	{
		scanf("%d %d %d",&k,&e,&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&s[i].x ,&s[i].f ,&s[i].c );
			if(s[i].x <=e)
			s[i].m =s[i].c +e-s[i].x ;
		}
		qsort(s,n,sizeof(s[0]),cmp);//从小到大排序 
		int sum=0;
		for(int i=0;i<n;i++)
		{
			if(k>s[i].f ) 
			{
			sum+=(s[i].f*s[i].m ) ;
			k-=s[i].f ;
			}
			else
			{
				sum+=(s[i].m *k);
				break;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值