1085: [SCOI2005]骑士精神

1085: [SCOI2005]骑士精神

Time Limit: 10 Sec   Memory Limit: 162 MB
Submit: 1557   Solved: 857
[ Submit][ Status][ Discuss]

Description

  在一个5×5的棋盘上有12个白色的骑士和12个黑色的骑士, 且有一个空位。在任何时候一个骑士都能按照骑
士的走法(它可以走到和它横坐标相差为1,纵坐标相差为2或者横坐标相差为2,纵坐标相差为1的格子)移动到空
位上。 给定一个初始的棋盘,怎样才能经过移动变成如下目标棋盘: 为了体现出骑士精神,他们必须以最少的步
数完成任务。

Input

  第一行有一个正整数T(T<=10),表示一共有N组数据。接下来有T个5×5的矩阵,0表示白色骑士,1表示黑色骑
士,*表示空位。两组数据之间没有空行。

Output

  对于每组数据都输出一行。如果能在15步以内(包括15步)到达目标状态,则输出步数,否则输出-1。

Sample Input

2
10110
01*11
10111
01001
00000
01011
110*1
01110
01010
00100

Sample Output

7
-1

HINT

Source

[ Submit][ Status][ Discuss]


迭代加深搜索+可行性剪枝(如果当前未归位的棋子大于剩余步数果断return)
苟蒻还是太弱。。碰到搜索题一脸懵逼

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;

const int dx[8] = {1,2,1,2,-1,-2,-1,-2};
const int dy[8] = {2,1,-2,-1,2,1,-2,-1};
const int goal = 549855;
const int c[5][5] = {{1,1,1,1,1},{0,1,1,1,1},{0,0,3,1,1},{0,0,0,0,1},{0,0,0,0,0}};

int n,m,cnt,ans,a[5][5],b[5][5];
char ch[10];

int calculate()
{
	int ret = 0;
	for (int j = 0; j < 5; j++)
		for (int l = 0; l < 5; l++)
			if (a[j][l] != 3)
				ret += a[j][l]*b[j][l];
	return ret;
}

bool dfs(int x,int y,short step,int now,int MAX)
{
	bool flag = 0; int tot = 0;
	if (step == MAX) return now == goal && x == 2 && y == 2;
	for (int i = 0; i < 5; i++)
		for (int j = 0; j < 5; j++)
			if (c[i][j] != 3 && c[i][j] != a[i][j])
				++tot;
	if (step + tot > MAX) return 0;
	for (int i = 0; i < 8; i++) {
		int xx = x + dx[i];
		int yy = y + dy[i];
		if (xx < 0 || xx > 4 || yy < 0 || yy > 4) continue;
		swap(a[x][y],a[xx][yy]);
		int next = calculate();
		if (dfs(xx,yy,step+1,next,MAX)) return 1;
		swap(a[x][y],a[xx][yy]);
	}
	return flag;
}

void PRE(int &x,int &y,int &now)
{
	for (int i = 0; i < 5; i++) {
		cin >> ch; 
		for (int j = 0; j < 5; j++) {
			if (ch[j] == '*') x = i,y = j,a[i][j] = 3;
			else a[i][j] = ch[j]-'0',now += b[i][j]*a[i][j];
		}
	}
}

int main()
{
	#ifdef YZY
		   freopen("yzy.txt","r",stdin);
	#endif
	
	cin >> n; int h = 0;
	for (int i = 0; i < 5; i++)
		for (int j = 0; j < 5; j++)
			b[i][j] = 1<<h,++h;
	for (cnt = 1; cnt <= n; cnt++) {
		int x,y,now = 0;
		PRE(x,y,now);
		for (ans = 1; ans <= 15; ans++)
			if (dfs(x,y,0,now,ans)) 
				break;
		if (ans > 15) ans = -1;
  		printf("%d\n",ans);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值