HDU 2680 Choose the best route (最短路+迪杰斯特拉)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2680


题面:

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10904    Accepted Submission(s): 3534


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
      
      
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
      
      
1 -1

题目大意:

    城市中有很多公交路线,Kiki可以从m个点出发,求到s点的最短距离。


解题:

    floyd明显是不可以的,可以设置一个超级源点,该源点到所有出发点的距离为0,然后求最短路,也可以将目标点设为出发点,求最短路,然后取所有m点中,耗费最小的点。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
using namespace std;
int map[1010][1010],dist[1010];
bool vis[1010];
void init(int n)
{
    for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
         {
            if(i==j)
              map[i][i]=0;
            else
              map[i][j]=inf;
         }
    for(int i=0;i<=n;i++)
      dist[i]=inf;
    memset(vis,0,sizeof(vis));
}
void dijkstra(int s,int n)
{
   int minn=inf,p,tmp;
   for(int i=0;i<=n;i++)
   {
     if((i!=s)&&map[s][i]<minn)
     {
        minn=map[s][i];
        p=i;
     }
   }
   dist[p]=minn;
   while(1)
   {
      vis[p]=1;
      for(int i=0;i<=n;i++)
      {
          tmp=dist[p]+map[p][i];
          if(tmp<dist[i])
            dist[i]=tmp;
      }
      minn=inf;
      for(int i=0;i<=n;i++)
      {
        if(!vis[i]&&dist[i]<minn)
        {
            minn=dist[i];
            p=i;
        }
      }
      if(minn==inf)
        break;
   }
}
int main()
{
	int n,m,s,p,q,t,w,tmp;
	while(~scanf("%d%d%d",&n,&m,&s))
	{
	   init(n);
	   for(int i=1;i<=m;i++)
	   {
	       scanf("%d%d%d",&p,&q,&t);
	       if(t<map[p][q])
	       map[p][q]=t;
       }
       scanf("%d",&w);
       for(int i=1;i<=w;i++)
       {
          scanf("%d",&tmp);
          map[0][tmp]=0;
          dist[tmp]=0;
       }
       dijkstra(0,n);
       if(dist[s]!=inf)
         printf("%d\n",dist[s]);
       else
         printf("-1\n");
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值