POJ 2117 Electricity 计算联通块的个数

Electricity
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3252 Accepted: 1097

Description

Blackouts and Dark Nights (also known as ACM++) is a company that provides electricity. The company owns several power plants, each of them supplying a small area that surrounds it. This organization brings a lot of problems - it often happens that there is not enough power in one area, while there is a large surplus in the rest of the country. 

ACM++ has therefore decided to connect the networks of some of the plants together. At least in the first stage, there is no need to connect all plants to a single network, but on the other hand it may pay up to create redundant connections on critical places - i.e. the network may contain cycles. Various plans for the connections were proposed, and the complicated phase of evaluation of them has begun. 

One of the criteria that has to be taken into account is the reliability of the created network. To evaluate it, we assume that the worst event that can happen is a malfunction in one of the joining points at the power plants, which might cause the network to split into several parts. While each of these parts could still work, each of them would have to cope with the problems, so it is essential to minimize the number of parts into which the network will split due to removal of one of the joining points. 

Your task is to write a software that would help evaluating this risk. Your program is given a description of the network, and it should determine the maximum number of non-connected parts from that the network may consist after removal of one of the joining points (not counting the removed joining point itself). 

Input

The input consists of several instances. 

The first line of each instance contains two integers 1 <= P <= 10 000 and C >= 0 separated by a single space. P is the number of power plants. The power plants have assigned integers between 0 and P - 1. C is the number of connections. The following C lines of the instance describe the connections. Each of the lines contains two integers 0 <= p1, p2 < P separated by a single space, meaning that plants with numbers p1 and p2 are connected. Each connection is described exactly once and there is at most one connection between every two plants. 

The instances follow each other immediately, without any separator. The input is terminated by a line containing two zeros. 

Output

The output consists of several lines. The i-th line of the output corresponds to the i-th input instance. Each line of the output consists of a single integer C. C is the maximum number of the connected parts of the network that can be obtained by removing one of the joining points at power plants in the instance.

Sample Input

3 3
0 1
0 2
2 1
4 2
0 1
2 3
3 1
1 0
0 0

Sample Output

1
2
2

Source


题意是说一共有n个核电站,让你求去掉一个点之后,最多剩下几部分联通。
先求出一共有多少个不连通的块,然后每个块去掉其割点,看一下哪个块分出的块数最多,最后加上块数,如果没有边连接,答案为n-1.

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 10007
using namespace std;
int low[M],dfn[M],vis[M],head[M];
int n,m,cnt,num,root,root_son,ans;
struct E
{
    int v,next;
}edg[M*20];
void addedge(int u,int v)
{
    edg[cnt].v=v;
    edg[cnt].next=head[u];
    head[u]=cnt++;
}
void init()
{
    memset(head,-1,sizeof(head));
    memset(low,0,sizeof(low));
    memset(vis,0,sizeof(vis));
    cnt=root_son=0;
}
void tarjan(int u,bool root)
{
    int child=0;
    vis[u]=1;
    dfn[u]=low[u]=++num;
    for(int i=head[u];i!=-1;i=edg[i].next)
    {
        int v=edg[i].v;
        if(!dfn[v])
        {
            tarjan(v,false);
            if(low[u]>low[v])
                low[u]=low[v];
            if(root)
                root_son++;
            else if(low[v]>=dfn[u])
                    child++;
        }
        else if(low[u]>dfn[v])
            low[u]=dfn[v];
    }
    ans=max(ans,child+1);
}

int solve(int x)
{
    memset(dfn,0,sizeof(dfn));
    num=root_son=ans=0;
    tarjan(x,true);
    if(root_son>1)
        ans=max(ans,root_son);
    return ans;
}
int main()
{
    while(scanf("%d%d",&n,&m),n|m)
    {
         if(m==0)
        {
            printf("%d\n",n-1);
            continue;
        }

        init();
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            addedge(a,b);
            addedge(b,a);
        }
        int count=0,maxx=0;
        for(int i=0;i<n;i++)
            if(!vis[i])
               {
                   count++;
                   maxx=max(maxx,solve(i));
               }
        printf("%d\n",count+maxx-1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值