hdu 3792 Twin Prime Conjecture 浙大复试上机题 水题

Twin Prime Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3211    Accepted Submission(s): 1138


Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

Sample Input
  
  
1 5 20 -2
 

Sample Output
  
  
0 1 4

 

用筛法求素数,然后用树状数组记录区间的孪生素数对。


#include<stdio.h> 

#define MAX 100100 

int ta[MAX*10];
int p[MAX] ;

int lowbit(int x)
{
	return x&(-x) ;
}

int sum(int x)
{
	int k = x ,sum = 0;
	while(k)
	{
		sum += ta[k] ;
		k -= lowbit(k) ;
	}
	return sum ;
}

void add(int x , int c)
{
	while(x<MAX*10)
	{
		ta[x] += c ;
		x += lowbit(x) ;
	}
}

void getPrime()
{
	for(int i=2 ; i < MAX ;++i)
	{
		for(int j = 2 ; i*j<=MAX ; ++j )
		{
			p[i*j] = true ;
		}
	}
}

void init()
{
	getPrime();
	for(int i = 4 ; i < MAX ; ++i)
	{
		if(!p[i-2]&&!p[i])
		{
			add(i,1) ;
		}
	}
}



int main()
{
	int n;
	init() ;
	while(~scanf("%d",&n) && n>=0)
	{
		printf("%d\n",sum(n)) ;
	}
	
	
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值