HDU1546 Idiomatic Phrases Game 最短路径(Dijkstra算法)

Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.


Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.


Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.


Sample Input
5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2 20 12345678ABCD
30 DCBF5432167D
0


Sample Output
17
-1
参考代码:
#include<iostream>
using namespace std;
#define INF 1000000000
#define MAXN 1000
struct idiom{
	char front[5],back[5];//记录成语的头尾两个字
	int T;
};
idiom dic[MAXN];//字典
int Edge[MAXN][MAXN];//邻接矩阵
int dist[MAXN];//可以说是记录权值
int S[MAXN];//判断是否加入顶点集合中
int N;
int main()
{
	int i,j,k;
	char s[100];
	int len;
	while(cin>>N)
	{
		if(N==0)
			break;
		for(k=0;k<N;k++)
		{
			cin>>dic[k].T>>s;
			len=strlen(s);
			for(i=0,j=len-1;i<4;i++,j--)
			{
				dic[k].front[i]=s[i];
				dic[k].back[3-i]=s[j];
			}
			dic[k].front[4]=dic[k].back[4]='\0';
		}
		for(i=0;i<N;i++)//建图
		{
			for(j=0;j<N;j++)
			{
				Edge[i][j]=INF;
				if(i==j)
					continue;
				if(strcmp(dic[i].back,dic[j].front)==0)
					Edge[i][j]=dic[i].T;
			}
		}
		//Dijskal算法的开始
		for(i=0;i<N;i++)//初始化
		{
			dist[i]=Edge[0][i];S[i]=0;
		}
		S[0]=1;
		dist[0]=0;//把顶点加入到顶点集合中
		for(i=0;i<N-1;i++)//确定N-1条路径
		{
			int min=INF;//选择当前集合T中具有最短路径的顶点u
			int u=0;
			for(j=0;j<N;j++)
			{
				if(!S[j]&&dist[j]<min)
				{
					u=j;
					min=dist[j];
				}
			}
			S[u]=1;//将u加入到顶点集合中
			for(k=0;k<N;k++)//修改集合T中的dist数组元素值
			{
				if(!S[k]&&Edge[u][k]<INF&&(dist[u]+Edge[u][k])<dist[k])
				{
					dist[k]=dist[u]+Edge[u][k];
				}
			}
		}
		if(dist[N-1]==INF)
			cout<<-1<<endl;
		else
			cout<<dist[N-1]<<endl;
		
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值