POJ 1459 Power Network(最大流)

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.


题目大意:

一个电力网络,有m条输电线路,每条线路的参数为(u,v)z,分别表示输电线路的起点终点以及最高输电容量;有n个节点,其中有np个发电站,每个发电站的参数为(u)z,分别表示节点编号和最大发电量,有nc个用户,每个用户的参数为(u)z,分别表示节点编号和最大接受量,问发电站通过该网络到达用户的最多电量。


网络流模板题,典型的增广路算法,需要处理的部分是发电站和用户节点,因为这些节点出现了容量限制,不能直接建图,所以要引入一个源点和一个汇点,源点与所有的发电站建立单向边,所有的用户与汇点建立单向边,建图,在新引入的源点汇点上跑一遍最大流即可。另外还需要注意的是题目的奇葩的格式输入,搞不好就会崩掉。。。


#include <iostream>
#include <fstream>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <bitset>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <list>
#include <ctime>

#define STD_REOPEN() freopen("../in.in","r",stdin)
#define STREAM_REOPEN fstream cin("../in.in")
#define INF 0x3f3f3f3f
#define _INF 63
#define eps 1e-4
#define MAX_V 100010
#define MAX_P 2010
#define MAX_E 4001000
#define MAX 32000
#define MOD_P 3221225473
#define MOD 9901

using namespace std;

struct edge
{
	int from,to,cap,flow;
	edge(int u,int v,int c,int f):from(u),to(v),cap(c),flow(f){}
};

struct EdmondsKarp
{
	int n,m;
	vector<edge> edges;
	vector<int> g[MAX_P];
	int a[MAX_P];
	int p[MAX_P];
	void init(int n)
	{
		this->n=n;
		for(int i=0;i<=n;i++)
			g[i].clear();
		edges.clear();
	}
	void AddEdge(int from,int to,int cap)
	{
		edges.push_back(edge(from,to,cap,0));
		edges.push_back(edge(to,from,0,0));
		m=edges.size();
		g[from].push_back(m-2);
		g[to].push_back(m-1);
	}
	int MaxFlow(int s,int t)
	{
		int flow=0;
		while(1)
		{
			memset(a,0,sizeof(a));
			queue<int> q;
			q.push(s);
			a[s]=INF;
			while(!q.empty())
			{
				int x=q.front();
				q.pop();
				int len=g[x].size();
				for(int i=0;i<len;i++)
				{
					edge &e=edges[g[x][i]];
					if(!a[e.to]&&e.cap>e.flow)
					{
						p[e.to]=g[x][i];
						a[e.to]=min(a[x],e.cap-e.flow);
						q.push(e.to);
					}
				}
				if(a[t])
					break;
			}
			if(!a[t])
				break;
			for(int u=t;u!=s;u=edges[p[u]].from)
			{
				edges[p[u]].flow+=a[t];
				edges[p[u]^1].flow-=a[t];
			}
			flow+=a[t];
		}
		return flow;
	}
}fl;

int main()
{
	//STD_REOPEN();
	int n,np,nc,m,u,v,c;
	while(~scanf("%d %d %d %d",&n,&np,&nc,&m))
	{
		fl.init(n+4);
		for(int i=0;i<m;i++)
		{
			scanf(" (%d,%d)%d",&u,&v,&c);
			fl.AddEdge(u,v,c);
		}
		int ss=n,tt=n+1;
		for(int i=0;i<np;i++)
		{
			scanf(" (%d)%d",&v,&c);
			fl.AddEdge(ss,v,c);
		}
		for(int i=0;i<nc;i++)
		{
			scanf(" (%d)%d",&u,&c);
			fl.AddEdge(u,tt,c);
		}
		printf("%d\n",fl.MaxFlow(ss,tt));
	}

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值