FOJ 1012 Relatives(欧拉值)

Problem Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

For each test case there should be single line of output answering the question posed above.

Sample Input

7120

Sample Output

64

 

这道题就是求比一个数小又和这个数互质的个数,就是欧拉值,这是前人已经推导出来了;

phi=n/(P1)*(P1-1)/P2*(P2-1)....../(Pn-1)*(Pn-1 - 1)/Pn*(Pn - 1),带公式就行;P是素因子

 

AC代码:

 

 

# include <stdio.h> 
# include <math.h>
# include <stdlib.h>
int euler_phi(int n){
	int m=sqrt(n+0.5);
	int ans=n;
	for(int i=2; i<=m; i++){
		if(n%i==0){
			ans=ans/i*(i-1);
		}
		while(n%i==0){
			n=n/i;
		}
	}
	if(n>1)
	ans=ans/n*(n-1);
	return ans;
}
int main(){
	int n;
	while(scanf("%d", &n)){
		if(n==0){
			break;
		}
		printf("%d\n", euler_phi(n));
	}
	return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值