HUDOJ 1060 Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13082    Accepted Submission(s): 5009


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
 
 
2 2 Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


题目链接 :http://acm.hdu.edu.cn/showproblem.php?pid=1060

题目大意 :求解n的n次方的最左边的数

题目分析 :1.直接用java的大数做(没什么技术含量,这里略)
         2.因为数字太大,考虑用对数  
           主要思路是任意数num可以表示为:num ^ num = a * 10 ^ n(a的整数部分即为所求解, n为位数)
           两边取对数:num * lg(num) = lg(a) + n,  令x = num * lg(num)  
           则n为x的整数部分,lg(a)为x的小数部分,所以lg(a) = x - n
           a = 10 ^ (x - n) => a = 10 ^ (x - (long long)x) 这里注意转换的的时候不能用int, 因为double表示的范围远大于int


#include <cmath>
#include <cstdio>
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {   
        int num;
        scanf("%d",&num);
        double x = num * log10(num);
        printf("%d\n", (int) pow(10.0 , (x - (long long)x)));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值