HDU OJ1060Leftmost Digit

HDU OJ1060Leftmost Digit


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

思路:参考网上大牛的想法

y=x^x

利用科学记数法表示y=p*10^n

p为所求

两边同时对x取以10为底对数

lg(p*10^n)=x*lg(x)

lgp+n=x*lgx

p=10^((x*lgx)-n)

10的任何整数次幂首数字都为1,所以最终结果取决于小数部分。

double   log(double x);   /* 计算一个数字的自然对数 */
double log10(double x);   /* 计算以10为基数的对数 */



注意:

1】x为__int64d类型

2】a-=(__int64)a;这句转换的时候,要注意a为double类型,精度比int小,所以转成(int)会出错,也可以定义a为long double类型


#include <stdio.h>
#include <math.h>

int main(){
	 __int64 x;
	int n,y;
	double a;
	scanf("%d",&n);
		
	while(n--){
		scanf("%I64d",&x);
		
		a=x*log10((double)x);
		a-=(__int64)a;
		printf("%d\n",(int)pow(10.0,a));
		
	}	
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值