1054. The Dominant Color (20)

题目:

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24

注意:
1、由于输入的数据可能非常大,所以建立一个索引表是不合适的。
2、这里建立了一个数值和索引的map,这样可以通过数值直接查询其对应的索引。
3、color和count保存map中每个索引对应的color值和出现的次数。

代码:
//1054
#include<iostream>
#include<vector>
#include<map>
using namespace std;

int main()
{
	int m,n;
	scanf("%d%d",&m,&n);
	map<int,int>color2index;
	vector<int>count;
	vector<int>color;
	int index=0;
	for(int i=0;i<m;++i)
	{
		for(int j=0;j<n;++j)
		{
			int t;
			scanf("%d",&t);
			if(color2index.find(t)==color2index.end())
			{
				color2index.insert(pair<int ,int>(t,index++));
				color.push_back(t);
				count.push_back(1);
			}
			else
				++count[color2index[t]];
		}
	}
	int max=0,k=0;
	for(int i=0;i<count.size();++i)
	{
		if(count[i]>max)
		{
			k=i;
			max=count[i];
		}
	}
	printf("%d\n",color[k]);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值