越獄之-卡车的历史(Truck History)

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.
/*
    题目的意思是给出N个由7个字符组成的卡车编码,他们都是唯一的。
    由每一对编码不同字符的数目来建立最小生成树,例如样例输入中
    给出的第一个和第二个就有1个字符不同,类似于a[i][j]。输出是要求
    输出生成树的权值之和的倒数。
*/

#include <algorithm>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#define INF 0x3f3f3f3f
using namespace std;

char str[2010][8];
bool vis[2010];
int dis[2010];
int f(char x[],char y[])
{
    int sum = 0;
    for(int i=0;i<7;i++)
    {
        if(x[i] != y[i])
            sum++;
    }
    return sum;
}
int lp(int n)
{
    int qmin,ans = 0,k,t;
    memset(vis,0,sizeof(vis));
    vis[1] = 1;
    dis[1] = 0;
    for(int i=2;i<=n;i++)
        dis[i] = f(str[1],str[i]);
    for(int i=2;i<=n;i++)
    {
        qmin = INF;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && qmin>dis[j])
            {
                k = j;
                qmin = dis[j];
            }
        }
        vis[k] = 1;
        ans+=qmin;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && (t=f(str[k],str[j]))< dis[j])
            {
                dis[j] = t;
            }
        }
    }
    return ans;
}
int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        for(int i=1;i<=n;i++)
            scanf("%s",str[i]);
        printf("The highest possible quality is 1/%d.\n",lp(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值