UVA 10881 - Piotr's Ants(等效变换)

Problem D
Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."

Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n  (0 <=  n <= 10000) . The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before Tseconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

题意:给定一根柱子上的蚂蚁,和她们开始方向和爬行时间,蚂蚁相遇会碰头调转。问最后蚂蚁的位置。

思路:蚂蚁的相对位置是不变的,第i个位置的蚂蚁最后还是在第i个位置。如此一来只要记录下蚂蚁的最终位置,最后在判断状态按一定顺序输出即可

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;
const int M = 10005;

int t, l, time, m, out[M];
map<int, int> vis;

struct Ant {
	int pos;
	char way[15];
	int num;
} ans[M];

int cmp(Ant a, Ant b) {
	return a.pos < b.pos;
}

void init() {
	int i;
	vis.clear();
	scanf("%d%d%d", &l, &time, &m);
	for (i = 0; i < m; i ++) {
		ans[i].num = i;
		scanf("%d%s", &ans[i].pos, ans[i].way);
	}
	sort(ans, ans + m, cmp);
	for (i = 0; i < m; i ++) {
		out[ans[i].num] = i;
		if (ans[i].way[0] == 'R') {
			ans[i].pos += time;
			vis[ans[i].pos] ++;
		}
		else {
			ans[i].pos -= time;
			vis[ans[i].pos] ++;
		}
	}
}

void solve() {
	sort(ans, ans + m, cmp);
	for (int j = 0; j < m; j ++) {
		int i = out[j];

		if (ans[i].pos < 0 || ans[i].pos > l) {
			printf("Fell off\n");
			continue;
		}
		printf("%d ", ans[i].pos);
		if (vis[ans[i].pos] >= 2)
			printf("Turning\n");
		else
			printf("%s\n", ans[i].way);
	}
	printf("\n");
}

int main() {
	scanf("%d", &t);
	int cas = 0;
	while (t--) {
		init();
		printf("Case #%d:\n", ++cas);
		solve();
	}
	return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值