【POJ2778】 DNA Sequence AC自动机+矩阵快速幂

5 篇文章 0 订阅
5 篇文章 0 订阅

DNA Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14224 Accepted: 5486

Description
It’s well known that DNA Sequence is a sequence only contains A, C, T and G, and it’s very useful to analyze a segment of DNA Sequence,For example, if a animal’s DNA sequence contains segment ATC then it may mean that the animal may have a genetic disease. Until now scientists have found several those segments, the problem is how many kinds of DNA sequences of a species don’t contain those segments.

Suppose that DNA sequences of a species is a sequence that consist of A, C, T and G,and the length of sequences is a given integer n.

Input
First line contains two integer m (0 <= m <= 10), n (1 <= n <=2000000000). Here, m is the number of genetic disease segment, and n is the length of sequences.

Next m lines each line contain a DNA genetic disease segment, and length of these segments is not larger than 10.

Output
An integer, the number of DNA sequences, mod 100000.

Sample Input

4 3
AT
AC
AG
AA

Sample Output

36

题意:给你n个病毒,求m长度的正常DNA序列的个数;
思路:在trie树上的递推,二维数组表示路径的方案数,快速幂解;
从0的dp[0][i]的和;

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
long long  b[110][110];
int n,m;
char s[115];
int MOD=100000;
int  ans=0;
int flag[110];
int tot;
int nex[110];
long long   cc[110][110];
long long  ccc[110][110];
struct node{
        int ch[4];
}t[110];
int val(char s)
{
    if(s=='A') return 0;
    if(s=='C') return 1;
    if(s=='T') return 2;
    if(s=='G') return 3;
}
inline void insert(char s[])
{
//  cout<<"     "<<s[0]<<endl;
//  cout<<tot<<endl;
    int now=0;
        for(int i=0;s[i];i++)
        {
        int ii=val(s[i]);
//cout<<i<<endl;
                if(!t[now].ch[ii])
                {
                        t[now].ch[ii]=++tot;
                }
                now=t[now].ch[ii];
        }
  flag[now]=1;
}
queue<int> q;
inline void AC()
{
        for(int i=0;i<4;i++) if(t[0].ch[i]) q.push(t[0].ch[i]);
        while(!q.empty())
        {
                int now=q.front();
                q.pop();
                int next=nex[now];
                for(int i=0;i<4;i++)
                {
        //  if(now==3) cout<<t[3].ch[2]<<endl;
        //  if(now==4)   cout<<"     "<<t[now].ch[i]<<endl;
                        if(t[now].ch[i])
                        {   
                                nex[t[now].ch[i]]=t[next].ch[i];
                                flag[t[now].ch[i]]|=flag[t[next].ch[i]];
                q.push(t[now].ch[i]);
                        }
                        else t[now].ch[i]=t[next].ch[i];
                }
        }
}
inline void ma_cheng(long long a[110][110],long long  tmp[110][110])
{
        for(int i=0;i<=tot;i++)
        for(int j=0;j<=tot;j++)
    {
        cc[i][j]=0;
        for(int k=0;k<=tot;k++)
            {
                    cc[i][j]+=a[i][k]*tmp[k][j];
                    cc[i][j]%=MOD;
            }

    }

//  for(int i=0;i<=5;i++)
    //{
    //for(int j=0;j<=5;j++)
    //cout<<cc[i][j]<<"   ";
    //cout<<endl;
    //}
//cout<<endl;

        for(int i=0;i<=tot;i++)
        for(int j=0;j<=tot;j++)
    {
        tmp[i][j]=cc[i][j];
    }
}
inline void ma_mi(int x)
{
    for(int i=0;i<=tot;i++)
    for(int j=0;j<=tot;j++)
    ccc[i][j]=b[i][j];
        while(x>0)
        {
//  cout<<"   "<<x<<endl;
                if(x&1) ma_cheng(ccc,b);
                ma_cheng(ccc,ccc);
                x>>=1;
        }
}
int main()
{
        scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        {
                scanf("%s",s);
                insert(s);
        }
        AC();
    //cout<<tot<<endl;
        for(int i=0;i<=tot;i++)
        if(!flag[i])
        {
                for(int j=0;j<4;j++)
                if(!flag[t[i].ch[j]])
                {
                        b[i][t[i].ch[j]]++;
                }
        }
//  cout<<tot<<endl;
    //for(int i=0;i<=7;i++)
//{

    //for(int j=0;j<=7;j++)
    //cout<<b[i][j]<<"   ";
//cout<<endl;
//}
        ma_mi(m-1);
    ans=0;
        for(int i=0;i<=tot;i++)
        if(!flag[i])
        {
                ans+=b[0][i];
        ans%=MOD;
        }
        cout<<ans<<endl;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值