1405_Tanning Salon

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.


Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0


Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.


Source: Mid-Central USA 2002


***************************************************************************************************************************************************

//和操作系统中的临界资源相似

#include<iostream>
#include<string>
using namespace std;
int main()
{
int num;
string cus;
string l_n;//保存第一次进来但是没有床位的字符
bool flag_1;
bool flag_2;
while(cin>>num&&num)
{


l_n.clear();
cin>>cus;
--num;
for(int i=1;i!=cus.size();i++)//从第二个字符开始与前面的字符分别匹配。成功->查找l_n,没有此字符,表明拥有资源者退出,++num;失败->表明第一次来->查num->若num>0,说明有资源,--num;若num=0;说明没有资源,将字符移入l_n
{   
flag_1=false;//这个位置很重要
for(int j=0;j!=i;j++)
{    

if(cus[i]==cus[j])
{  
flag_2=false;//这个位置很重要
flag_1=true;
for(int k=0;k!=l_n.size();k++)
if(cus[j]==l_n[k])
{
flag_2=true;
break;
}
if(flag_2==false)
++num;
break;
   }
    }
if(flag_1==false)
 if(num==0)
l_n+=cus[i];
 else
--num;
}
if(l_n.size()==0)
cout<<"All customers tanned successfully."<<endl;
else
  cout<<l_n.size()<<" customer(s) walked away."<<endl;


}
return 0;
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值