POJ1250:Tanning Salon

Description

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.
 
 
题意:有n个位置,每个字母第一次出现代表客人的进来,第二次出现代表离开
统计流失了几个客户

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

char s[100005];

int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        int l=0,i,j,flag,len;
        scanf("%s",s);
        len = strlen(s);
        char z[25];//Z数组存床是否有人
        memset(z,'#',sizeof(z));
        for(i=0; i<len; i++)
        {
            flag=0;//flag=0表示进入
            for(j=1; j<=n; j++) //离开后位置清空
                if(z[j]==s[i])
                {
                    z[j]='#';
                    flag=1;
                    break;
                }
            if(flag==0)
                for(j=1; j<=n; j++) //有空位置就让顾客进去
                    if(z[j]=='#')
                    {
                        z[j]=s[i];
                        break;
                    }
            if(j>n)//没有空位置流失人数加一
                l++;
        }
        if(l==0)
            printf("All customers tanned successfully.\n");
        else
            printf("%d customer(s) walked away.\n",l/2);
    }
    return 0;
}


 


                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值