poj 3320 Jessica's Reading Problem 【尺取法+STLmap set】

2 篇文章 0 订阅

Jessica's Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7893 Accepted: 2529

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line containsP non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2
题意:要复习P页的书籍,每页都有一个知识点,同一个知识的可能出现在不同页。问最少需要看的连续的页数才能看完所有的知识点。
尺取法:从区间的起始和结尾进行修改和更新。
思路:首先找到最初能够覆盖所有知识点的连续的页(用一个变量num来记录已出现的不同的知识点,用s表示区间头部,t表示区间尾部),若不能找到,说明从当前区间头部到最后一页的整个区间都不能覆盖所有知识点,那么不用往后找了,跳出;若能找到就更新区间长度,然后修改区间头部,(这里要注意:若区间头部对应的知识点在当前区间只出现一次就把知识点总数num减一)。下面操作一样的,不断更新与修改,直到当前区间头部->最后一页不能覆盖所有知识为止。
提醒:我们用知识点和出现在当前区间的次数建立映射map,用set来记录不同的知识的个数。
#include <cstdio>
#include <cstring>
#include <map>
#include <set>
#include <algorithm>
#define MAX 1000000+10
using namespace std;
int P, n;
int a[MAX];
void solve()
{
	int t, s, num;//t起始页数 s末页数 num看的知识点数 
	int ans = P;//最多看P页 
	map<int, int> count;//知识点到出现次数的映射 
	t = s = num = 0;
	for(;;)
	{
		while(t < P && num < n)//找够n个知识点为止 
		{
			if(count[a[t++]]++ == 0)//当前知识点没出现 
			num++;//继续查找 并增加已经看的知识点数 
		}
		if(num < n)//当前找不到 后面也不会找到 
		break;
		ans = min(ans, t-s);//更新
		if(--count[a[s++]] == 0)//如果s对应页数的知识点只出现一次 
		num--;//知识点数目减一 
	}
	printf("%d\n", ans); 
}
int main()
{
	while(scanf("%d", &P) != EOF)
	{
		set<int> all;//用set的性质记录知识点个数 
		for(int i = 0; i < P; i++)
		{
			scanf("%d", &a[i]);
			all.insert(a[i]);
		}
		n = all.size();
		solve();
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值