Candies POJ - 3159 (差分约束+最短路)

Candies

POJ - 3159

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4
Sample Output
5
Hint
32-bit signed integer type is capable of doing all arithmetic.

首先如果你不知道差分约束系统是什么请看下面链接

差分约束系统详解

http://www.cppblog.com/menjitianya/archive/2015/11/19/212292.html

code:

/**
题意:给n个人分配糖果,给出m组数据,每组数据包含A,B,c三个数
意思是B的糖果数比A多的个数不能超过c,也就是Numb - Numa <= c;
最后求n比1最多可以多多少个糖果

解题思路:
这是一道查分约束题,不妨将糖果数当做距离,把两个人之间不能超过的
那个差值看成有向边AB的权值,则根据题目的意思我们就可以得到
dis[B] - dis[A] <= w(A,B),那么这个问题就可以转化成判断
dis[B] > dis[A] + w(A,B),如果为真,就更新使得dis[B] = dis[A] + w(A,B)
这样就变成了求最短路
spfa + stack 使用邻接表
**/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN = 30010;
const int MAXE = 150010;
const int INF = 0x3f3f3f3f;
int first[MAXN];//储蓄每个顶点的第一条边的编号
int vis[MAXN];//标记数组

int Q[MAXN];//栈模拟数组
int dis[MAXN];//距离
struct Edge{
    int to;
    int v;
    int next;
}edge[MAXE];
int tol;
void add(int a,int b,int v){//加边
    edge[tol].to = b;
    edge[tol].v = v;
    //这两句为邻接表的关键语句
    edge[tol].next = first[a];//先更新第一条边的下一条边,把下一条边更新成当前的第一条边
    first[a] = tol;//然后在更新第一条边

    tol++;
}
void spfa(int start,int n){
    int top = -1;
    memset(dis,INF,sizeof(dis));
    memset(vis,0,sizeof(vis));
    dis[start] = 0;
    vis[start] = 1;
    Q[++top] = start;
    while(top > -1){
        int u = Q[top--];
        vis[u] = 0;
        int i;
        for(i = first[u]; i != -1; i = edge[i].next){
            int v = edge[i].to;
            if(dis[v] > dis[u] + edge[i].v){
                dis[v] = dis[u] + edge[i].v;
                if(!vis[v]){
                    vis[v] = 1;
                    Q[++top] = v;
                }
            }
        }
    }
}
int main(){
    int n;
    int M;
    int a,b,c;
    while(~scanf("%d%d",&n,&M)){
        tol = 0;//给每条边编号
        memset(first,-1,sizeof(first));
        while(M--){
            scanf("%d%d%d",&a,&b,&c);
            //b-a <= c
            add(a,b,c);
        }
        spfa(1,n);
        cout << dis[n] << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值