poj 3159 Candies(优先队列 dijkstra+堆)

题目链接

http://poj.org/problem?id=3159

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 26118 Accepted: 7147

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get overc candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5
题目大意:

有N个孩子(N<=3000)分糖果。 有M个关系(M<=150,000)。每个关系形如:  A B C   
表示第B个学生比第A个学生多分到的糖果数目,不能超过C  
求第N个学生最多比第1个学生能多分几个糖果 

AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct Node{
    int k;
    int w;
};
bool operator<(const Node &a,const Node &b)
{return a.w>b.w;}
priority_queue<Node> pq;
bool bUsed[30010]={0};
vector<vector<Node> > v;
const unsigned int inf=1000000000;
int main()
{
    int n,m,a,b,c;
    int i,j,k;
    Node p;
    scanf("%d%d",&n,&m);
    v.clear();
    v.resize(n+1);
    memset(bUsed,0,sizeof(bUsed));
    for(i=1;i<=m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        p.k=b;
        p.w=c;
        v[a].push_back(p);
    }
    p.k=1;
    p.w=0;
    pq.push(p);
    while(!pq.empty()){
        p=pq.top();
        pq.pop();
        if(bUsed[p.k])
            continue;
        bUsed[p.k]=true;
        if(p.k==n)
            break;
        for(i=0,j=v[p.k].size();i<j;i++){
            Node q;
            q.k=v[p.k][i].k;
            if(bUsed[q.k]) continue;
            q.w=p.w+v[p.k][i].w;
            pq.push(q);
        }
    }
    printf("%d",p.w);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值