POJ1455 Crazy tea patry

Description
n participants of << crazy tea party >> sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).

Input
The first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.

Output
For each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.

Sample Input
3
4
5
6

Sample Output
2
4

6


本题意思是:环形序列逆序排列

                       首先想到冒泡的方法,如果不是环形,就能直接用冒泡的式子:即为n*(n-1)*0.5

                       现在的难点在于是环形,想到将环形转化为2个非环形

                        如果n是偶数,则两部分相等,均为0.5*n

                        如果n是奇数,则分成(n-1)*0.5和(n-1)*0.5+1


#include<stdio.h>
#include<stdlib.h>
int main()
{
int N,n;
int i;
scanf("%d",&N);
for(i=0;i<N;i++)
{
int ans;
scanf("%d",&n);
if(n%2==0)
ans=(n/2)*(n/2-1);
else
ans=0.5*(n/2)*(n/2-1)+0.5*(n/2+1)*(n/2);
printf("%d\n",ans);
}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值